summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-09 03:24:42 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-09 03:24:42 +0000
commit80cfe3ad9373c2fbee5ae62d404ac8af97b2d515 (patch)
tree7f06bc4633dd486c4c1e0036354ba5409125cbab /dev-python/pycairo
parentVersion bump. (diff)
downloadgentoo-2-80cfe3ad9373c2fbee5ae62d404ac8af97b2d515.tar.gz
gentoo-2-80cfe3ad9373c2fbee5ae62d404ac8af97b2d515.tar.bz2
gentoo-2-80cfe3ad9373c2fbee5ae62d404ac8af97b2d515.zip
Version bump.
(Portage version: 13808-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/ChangeLog8
-rw-r--r--dev-python/pycairo/pycairo-1.8.6.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/pycairo/ChangeLog b/dev-python/pycairo/ChangeLog
index 282af8492efd..89d679355f53 100644
--- a/dev-python/pycairo/ChangeLog
+++ b/dev-python/pycairo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pycairo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.67 2009/05/01 16:44:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.68 2009/07/09 03:24:42 arfrever Exp $
+
+*pycairo-1.8.6 (09 Jul 2009)
+
+ 09 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pycairo-1.8.6.ebuild:
+ Version bump.
01 May 2009; Raúl Porcel <armin76@gentoo.org> pycairo-1.8.2.ebuild:
alpha/arm/ia64/sh/sparc stable wrt #267433
diff --git a/dev-python/pycairo/pycairo-1.8.6.ebuild b/dev-python/pycairo/pycairo-1.8.6.ebuild
new file mode 100644
index 000000000000..81d642af0433
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.8.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.8.6.ebuild,v 1.1 2009/07/09 03:24:42 arfrever Exp $
+
+NEED_PYTHON="2.6"
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for cairo vector graphics library"
+HOMEPAGE="http://cairographics.org/pycairo/"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=x11-libs/cairo-1.8.6"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PYTHON_MODNAME="cairo"
+DOCS="AUTHORS NEWS doc/*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't run py-compile.
+ sed -i \
+ -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
+ cairo/Makefile.in || die "sed in cairo/Makefile.in failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ rm "${D}"/usr/share/doc/${PF}/examples/Makefile*
+ fi
+}
+
+src_test() {
+ cd test
+ PYTHONPATH="$(ls -d ${S}/build/lib.*)" "${python}" test.py || die "tests failed"
+}