summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-02-23 14:46:43 +0000
committerIan Delaney <idella4@gentoo.org>2015-02-23 14:46:43 +0000
commitf6c6cbc6dc2b849f1c7d759e65db9c9f3f9f41d4 (patch)
treee49c9b53d35ad5aaf576fb71d692a361f5f2b33a /dev-python/pyclimate
parentversion bump fix #536784 (diff)
downloadgentoo-2-f6c6cbc6dc2b849f1c7d759e65db9c9f3f9f41d4.tar.gz
gentoo-2-f6c6cbc6dc2b849f1c7d759e65db9c9f3f9f41d4.tar.bz2
gentoo-2-f6c6cbc6dc2b849f1c7d759e65db9c9f3f9f41d4.zip
revbump; convert -> distutils-r1, add python herd, agreement with jlec
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyclimate')
-rw-r--r--dev-python/pyclimate/ChangeLog10
-rw-r--r--dev-python/pyclimate/metadata.xml3
-rw-r--r--dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild4
-rw-r--r--dev-python/pyclimate/pyclimate-1.2.2-r2.ebuild39
4 files changed, 51 insertions, 5 deletions
diff --git a/dev-python/pyclimate/ChangeLog b/dev-python/pyclimate/ChangeLog
index bd3f13a0cfc0..51f0ee6c5f1d 100644
--- a/dev-python/pyclimate/ChangeLog
+++ b/dev-python/pyclimate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyclimate
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclimate/ChangeLog,v 1.27 2012/10/07 08:57:52 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclimate/ChangeLog,v 1.28 2015/02/23 14:46:43 idella4 Exp $
+
+*pyclimate-1.2.2-r2 (23 Feb 2015)
+
+ 23 Feb 2015; Ian Delaney <idella4@gentoo.org> +pyclimate-1.2.2-r2.ebuild,
+ metadata.xml, pyclimate-1.2.2-r1.ebuild:
+ revbump; convert -> distutils-r1, add python herd, agreement with jlec
07 Oct 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, #24135.
diff --git a/dev-python/pyclimate/metadata.xml b/dev-python/pyclimate/metadata.xml
index 3404ff9dd4d4..056e23c1e4fc 100644
--- a/dev-python/pyclimate/metadata.xml
+++ b/dev-python/pyclimate/metadata.xml
@@ -1,7 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
+ <herd>sci</herd>
+ <herd>python</herd>
<longdescription>
A package designed to accomplish some usual tasks during the analysis of
climate variability using Python. It provides functions to perform some
diff --git a/dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild b/dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild
index 6995e7f44e88..188910e3f7a1 100644
--- a/dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild
+++ b/dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild,v 1.10 2012/02/23 08:02:18 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild,v 1.11 2015/02/23 14:46:43 idella4 Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
diff --git a/dev-python/pyclimate/pyclimate-1.2.2-r2.ebuild b/dev-python/pyclimate/pyclimate-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..566d57948c3f
--- /dev/null
+++ b/dev-python/pyclimate/pyclimate-1.2.2-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclimate/pyclimate-1.2.2-r2.ebuild,v 1.1 2015/02/23 14:46:43 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+MY_P="${P/pyclimate/PyClimate}"
+
+DESCRIPTION="Climate Data Analysis Module for Python"
+HOMEPAGE="http://www.pyclimate.org/"
+SRC_URI="http://fisica.ehu.es/jsaenz/pyclimate_files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/scientificpython-2.8[${PYTHON_USEDEP}]
+ >=sci-libs/netcdf-3.0"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+ dodoc doc/manual.ps doc/dcdflib_doc/dcdflib*
+}