summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-07-08 05:19:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-07-08 05:19:03 +0000
commit62e1623d7b1c14a2ab4fbc6e5cb053658e00b4ff (patch)
treee2b5280356655b1dc4feceb44f5ea692de35bf4e /dev-python/pycountry
parentCleanup. (diff)
downloadgentoo-2-62e1623d7b1c14a2ab4fbc6e5cb053658e00b4ff.tar.gz
gentoo-2-62e1623d7b1c14a2ab4fbc6e5cb053658e00b4ff.tar.bz2
gentoo-2-62e1623d7b1c14a2ab4fbc6e5cb053658e00b4ff.zip
Bump
(Portage version: 2.2.0_alpha187/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pycountry')
-rw-r--r--dev-python/pycountry/ChangeLog7
-rw-r--r--dev-python/pycountry/pycountry-0.16.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/pycountry/ChangeLog b/dev-python/pycountry/ChangeLog
index ebadd82f30d1..309c612d08c3 100644
--- a/dev-python/pycountry/ChangeLog
+++ b/dev-python/pycountry/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycountry
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycountry/ChangeLog,v 1.14 2013/06/29 15:59:39 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycountry/ChangeLog,v 1.15 2013/07/08 05:19:03 patrick Exp $
+
+*pycountry-0.16 (08 Jul 2013)
+
+ 08 Jul 2013; Patrick Lauer <patrick@gentoo.org> +pycountry-0.16.ebuild:
+ Bump
*pycountry-0.15 (29 Jun 2013)
diff --git a/dev-python/pycountry/pycountry-0.16.ebuild b/dev-python/pycountry/pycountry-0.16.ebuild
new file mode 100644
index 000000000000..e8b59cf65165
--- /dev/null
+++ b/dev-python/pycountry/pycountry-0.16.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycountry/pycountry-0.16.ebuild,v 1.1 2013/07/08 05:19:03 patrick Exp $
+
+EAPI=5
+# pypy pennding actioning of bug filed upstream
+PYTHON_COMPAT=( python{2_6,2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="ISO country, subdivision, language, currency and script definitions and their translations"
+HOMEPAGE="http://pypi.python.org/pypi/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( HISTORY.txt TODO.txt )
+
+# https://bitbucket.org/techtonik/pycountry/issue/9/can-pytest-extras-be-removed-015
+PATCHES=( "${FILESDIR}"/${PN}-0.15-setup.patch )
+
+python_test() {
+ # https://bitbucket.org/techtonik/pycountry/issue/8/test_locales-pycountry-015-pypy
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ py.test ${PN}/tests/test_general.py || die
+}