summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-26 23:39:43 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-26 23:39:43 +0000
commit66b12afbc19dd18aa3a2b73fb94ebcef95481dba (patch)
treea547bf84ebe2dee2217f0edf3a282c366427211f /dev-python/pycrypto/pycrypto-2.0.1-r5.ebuild
parentAdded -alpha keyword. Doesn't work on alpha. (diff)
downloadgentoo-2-66b12afbc19dd18aa3a2b73fb94ebcef95481dba.tar.gz
gentoo-2-66b12afbc19dd18aa3a2b73fb94ebcef95481dba.tar.bz2
gentoo-2-66b12afbc19dd18aa3a2b73fb94ebcef95481dba.zip
Fix from upstream for SHA256 #131293 by Ciaran McCreesh.
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'dev-python/pycrypto/pycrypto-2.0.1-r5.ebuild')
-rw-r--r--dev-python/pycrypto/pycrypto-2.0.1-r5.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pycrypto/pycrypto-2.0.1-r5.ebuild b/dev-python/pycrypto/pycrypto-2.0.1-r5.ebuild
new file mode 100644
index 000000000000..48c0722e0c93
--- /dev/null
+++ b/dev-python/pycrypto/pycrypto-2.0.1-r5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycrypto/pycrypto-2.0.1-r5.ebuild,v 1.1 2006/04/26 23:39:43 vapier Exp $
+
+inherit eutils distutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Python Cryptography Toolkit"
+HOMEPAGE="http://www.amk.ca/python/code/crypto.html"
+SRC_URI="http://www.amk.ca/files/python/crypto/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="bindist gmp test"
+
+RDEPEND="virtual/python
+ gmp? ( dev-libs/gmp )"
+DEPEND="${RDEPEND}
+ test? ( =dev-python/sancho-0.11-r1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use bindist && epatch "${FILESDIR}"/${P}-bindist.patch
+ epatch "${FILESDIR}"/${P}-sha256.patch
+ epatch "${FILESDIR}"/${P}-gmp.patch
+ epatch "${FILESDIR}"/pycrypto-2.0.1-uint32.patch
+ epatch "${FILESDIR}"/${P}-sancho-package-rename.patch
+}
+
+src_compile() {
+ use gmp \
+ && export USE_GMP=1 \
+ || export USE_GMP=0
+ # sha256 hashes occasionally trigger ssp when built with
+ # -finline-functions (implied by -O3).
+ gcc-specs-ssp && append-flags -fno-inline-functions
+ distutils_src_compile
+}
+
+src_test() {
+ export PYTHONPATH=$(ls -d "${S}"/build/lib.*/)
+ python ./test.py || die "test failed"
+ if use test ; then
+ local x
+ cd test
+ for x in test_*.py ; do
+ python ${x} || die "${x} failed"
+ done
+ fi
+}
+
+DOCS="ACKS ChangeLog PKG-INFO README TODO Doc/pycrypt.tex"