summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-08-24 03:48:30 +0000
committerTim Harder <radhermit@gentoo.org>2014-08-24 03:48:30 +0000
commit2bd48096793dc8890e7ee7fd5e863a9aee62d5e7 (patch)
treefc74fe503c1029571a613fb1094baf23ec776832 /dev-python/pygit2
parentVersion bump. (diff)
downloadgentoo-2-2bd48096793dc8890e7ee7fd5e863a9aee62d5e7.tar.gz
gentoo-2-2bd48096793dc8890e7ee7fd5e863a9aee62d5e7.tar.bz2
gentoo-2-2bd48096793dc8890e7ee7fd5e863a9aee62d5e7.zip
Version bump (bug #520324).
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/ChangeLog7
-rw-r--r--dev-python/pygit2/pygit2-0.21.2.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-python/pygit2/ChangeLog b/dev-python/pygit2/ChangeLog
index 39c1f1735b5c..41a2a52476d6 100644
--- a/dev-python/pygit2/ChangeLog
+++ b/dev-python/pygit2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pygit2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/ChangeLog,v 1.28 2014/07/24 02:27:04 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/ChangeLog,v 1.29 2014/08/24 03:48:30 radhermit Exp $
+
+*pygit2-0.21.2 (24 Aug 2014)
+
+ 24 Aug 2014; Tim Harder <radhermit@gentoo.org> +pygit2-0.21.2.ebuild:
+ Version bump (bug #520324).
*pygit2-0.21.1 (24 Jul 2014)
diff --git a/dev-python/pygit2/pygit2-0.21.2.ebuild b/dev-python/pygit2/pygit2-0.21.2.ebuild
new file mode 100644
index 000000000000..81a9860a7ddb
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.21.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/pygit2-0.21.2.ebuild,v 1.1 2014/08/24 03:48:30 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2"
+SRC_URI="https://github.com/libgit2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-libs/libgit2-$(get_version_component_range 1-2)*
+ dev-python/cffi[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}