summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-11-24 23:13:31 +0000
committerTim Harder <radhermit@gentoo.org>2013-11-24 23:13:31 +0000
commit818a582d940758a13c562b03a547f52c28d8f64b (patch)
tree992f4d2bf29a0f33b57896752f5cb373c2846df6 /dev-python/pygit2
parentVersion bump, add trace use flag. (diff)
downloadgentoo-2-818a582d940758a13c562b03a547f52c28d8f64b.tar.gz
gentoo-2-818a582d940758a13c562b03a547f52c28d8f64b.tar.bz2
gentoo-2-818a582d940758a13c562b03a547f52c28d8f64b.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/ChangeLog7
-rw-r--r--dev-python/pygit2/pygit2-0.20.0.ebuild23
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-python/pygit2/ChangeLog b/dev-python/pygit2/ChangeLog
index 9f66b6d42b36..d33125c0476e 100644
--- a/dev-python/pygit2/ChangeLog
+++ b/dev-python/pygit2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pygit2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/ChangeLog,v 1.20 2013/10/18 09:47:36 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/ChangeLog,v 1.21 2013/11/24 23:13:31 radhermit Exp $
+
+*pygit2-0.20.0 (24 Nov 2013)
+
+ 24 Nov 2013; Tim Harder <radhermit@gentoo.org> +pygit2-0.20.0.ebuild:
+ Version bump.
*pygit2-0.19.1 (18 Oct 2013)
diff --git a/dev-python/pygit2/pygit2-0.20.0.ebuild b/dev-python/pygit2/pygit2-0.20.0.ebuild
new file mode 100644
index 000000000000..1ed2bd9a1cea
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.20.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/pygit2-0.20.0.ebuild,v 1.1 2013/11/24 23:13:31 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2"
+SRC_URI="https://github.com/libgit2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=dev-libs/libgit2-$(get_version_component_range 1-2)*"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}