summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-23 07:51:53 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-23 07:51:53 +0000
commit0e291c934939b36b6c5a26ca65ca9de371fc802f (patch)
tree57e93a2deb12fbe069ef049e6dbc7b22ea6cea6b /dev-python/pygobject
parent[bump] dev-perl/HTML-Mason-1.470.0 (diff)
downloadgentoo-2-0e291c934939b36b6c5a26ca65ca9de371fc802f.tar.gz
gentoo-2-0e291c934939b36b6c5a26ca65ca9de371fc802f.tar.bz2
gentoo-2-0e291c934939b36b6c5a26ca65ca9de371fc802f.zip
Version bump, disable tests that require unreleased gobject-introspection.
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pygobject')
-rw-r--r--dev-python/pygobject/ChangeLog10
-rw-r--r--dev-python/pygobject/files/pygobject-3.0.2-disable-new-gi-tests.patch29
-rw-r--r--dev-python/pygobject/pygobject-3.0.2.ebuild117
3 files changed, 155 insertions, 1 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index aa8cc6a05a93..ecdae2c76ccc 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.126 2011/10/19 01:23:24 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.127 2011/10/23 07:51:53 tetromino Exp $
+
+*pygobject-3.0.2 (23 Oct 2011)
+
+ 23 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +pygobject-3.0.2.ebuild, +files/pygobject-3.0.2-disable-new-gi-tests.patch:
+ Version bump. Disable tests that require new regression functions present
+ only in git master of gobject-introspection.
+ Notable features: several important bugfixes, unbreaks gdk-2 support.
*pygobject-3.0.1 (19 Oct 2011)
*pygobject-2.28.6-r50 (19 Oct 2011)
diff --git a/dev-python/pygobject/files/pygobject-3.0.2-disable-new-gi-tests.patch b/dev-python/pygobject/files/pygobject-3.0.2-disable-new-gi-tests.patch
new file mode 100644
index 000000000000..8fa2ceed9654
--- /dev/null
+++ b/dev-python/pygobject/files/pygobject-3.0.2-disable-new-gi-tests.patch
@@ -0,0 +1,29 @@
+Disable tests requiring an unreleased version of gobject-introspection.
+
+diff --git a/tests/test_everything.py b/tests/test_everything.py
+index 19d345b..4a03890 100644
+--- a/tests/test_everything.py
++++ b/tests/test_everything.py
+@@ -483,22 +483,3 @@ class TestAdvancedInterfaces(unittest.TestCase):
+ self.assertEquals(ret[0], 51);
+ self.assertEquals(ret[1], 61);
+ self.assertEquals(ret[2], 32);
+-
+- def test_obj_skip_return_val_no_out(self):
+- obj = Everything.TestObj();
+- # raises an error for 0, succeeds for any other value
+- self.assertRaises(GLib.GError, obj.skip_return_val_no_out, 0)
+-
+- ret = obj.skip_return_val_no_out(1)
+- self.assertEquals(ret, None)
+-
+-class TestSignals(unittest.TestCase):
+- def test_object_param_signal(self):
+- obj = Everything.TestObj();
+-
+- def callback (obj_param):
+- self.assertEquals(obj_param.props.int, 3)
+- self.assertEquals(obj_param.__grefcount__, 2)
+-
+- obj.connect('sig-with-obj', callback)
+- obj.emit_sig_with_obj()
diff --git a/dev-python/pygobject/pygobject-3.0.2.ebuild b/dev-python/pygobject/pygobject-3.0.2.ebuild
new file mode 100644
index 000000000000..13bd94886173
--- /dev/null
+++ b/dev-python/pygobject/pygobject-3.0.2.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-3.0.2.ebuild,v 1.1 2011/10/23 07:51:53 tetromino Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="xz"
+GNOME2_LA_PUNT="yes"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2:2.6 3:3.1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.0 *-jython"
+
+# XXX: Is the alternatives stuff needed anymore?
+inherit alternatives autotools gnome2 python virtualx
+
+DESCRIPTION="GLib's GObject library bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+cairo examples test +threads" # doc
+
+COMMON_DEPEND=">=dev-libs/glib-2.24.0:2
+ >=dev-libs/gobject-introspection-1.29
+ virtual/libffi
+ cairo? ( >=dev-python/pycairo-1.10.0 )"
+DEPEND="${COMMON_DEPEND}
+ test? (
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ >=dev-libs/gobject-introspection-1.29.17 )
+ >=dev-util/pkgconfig-0.12"
+# docs disabled for now per upstream default since they are very out of date
+# doc? (
+# app-text/docbook-xml-dtd:4.1.2
+# dev-libs/libxslt
+# >=app-text/docbook-xsl-stylesheets-1.70.1 )
+
+# We now disable introspection support in slot 2 per upstream recommendation
+# (see https://bugzilla.gnome.org/show_bug.cgi?id=642048#c9); however,
+# older versions of slot 2 installed their own site-packages/gi, and
+# slot 3 will collide with them.
+RDEPEND="${COMMON_DEPEND}
+ !<dev-python/pygtk-2.13
+ !<dev-python/pygobject-2.28.6-r50:2[introspection]"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog* NEWS README"
+ # Hard-enable libffi support since both gobject-introspection and
+ # glib-2.29.x rdepend on it anyway
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --with-ffi
+ $(use_enable cairo)
+ $(use_enable threads thread)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not build tests if unneeded, bug #226345
+ epatch "${FILESDIR}/${PN}-2.90.1-make_check.patch"
+
+ # Support installation for multiple Python versions, upstream bug #648292
+ epatch "${FILESDIR}/${PN}-3.0.0-support_multiple_python_versions.patch"
+
+ # Disable tests that fail
+ #epatch "${FILESDIR}/${PN}-2.28.3-disable-failing-tests.patch"
+
+ # FIXME: disable tests that require git master of gobject-introspection
+ epatch "${FILESDIR}/${P}-disable-new-gi-tests.patch"
+
+ # disable pyc compiling
+ ln -sfn $(type -P true) py-compile
+
+ eautoreconf
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_execute_function -s gnome2_src_configure
+}
+
+src_compile() {
+ python_execute_function -d -s
+}
+
+# FIXME: With python multiple ABI support, tests return 1 even when they pass
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ testing() {
+ XDG_CACHE_HOME="${T}/$(PYTHON --ABI)"
+ Xemake check PYTHON=$(PYTHON -a)
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ python_execute_function -s gnome2_src_install
+ python_clean_installation_image
+
+ if use examples; then
+ insinto /usr/share/doc/${P}
+ doins -r examples || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize gi
+}
+
+pkg_postrm() {
+ python_mod_cleanup gi
+}