summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2003-10-30 01:40:43 +0000
committerRob Cakebread <pythonhead@gentoo.org>2003-10-30 01:40:43 +0000
commit9e3120b1bb873517c78d1138d25516d7c4ba007b (patch)
tree524bd48ca1098b694902bb76a2c1a478c451279d /dev-python/pyltxml/pyltxml-1.3.ebuild
parentInitial commit (diff)
downloadgentoo-2-9e3120b1bb873517c78d1138d25516d7c4ba007b.tar.gz
gentoo-2-9e3120b1bb873517c78d1138d25516d7c4ba007b.tar.bz2
gentoo-2-9e3120b1bb873517c78d1138d25516d7c4ba007b.zip
Initial commit
Diffstat (limited to 'dev-python/pyltxml/pyltxml-1.3.ebuild')
-rw-r--r--dev-python/pyltxml/pyltxml-1.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyltxml/pyltxml-1.3.ebuild b/dev-python/pyltxml/pyltxml-1.3.ebuild
new file mode 100644
index 000000000000..c4af2f0b5ad5
--- /dev/null
+++ b/dev-python/pyltxml/pyltxml-1.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyltxml/pyltxml-1.3.ebuild,v 1.1 2003/10/30 01:40:37 pythonhead Exp $
+
+inherit distutils
+
+S="${WORKDIR}/PyLTXML-${PV}"
+DESCRIPTION="Bindings for LTXML libraries"
+HOMEPAGE="http://www.ltg.ed.ac.uk/software/xml/"
+SRC_URI=ftp://ftp.cogsci.ed.ac.uk/pub/LTXML/PyLTXML-${PV}.tar.gz
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DOCS="00README"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e s':projects/ltg/projects/lcontrib/include:usr/include:' \
+ -e s':projects/ltg/projects/lcontrib/lib:usr/lib/ltxml12:' \
+ setup.py \
+ || die "sed failed on setup.py"
+}
+