summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-11-27 02:33:28 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-11-27 02:33:28 +0000
commitb2a0dc38932ca8b86a64aa1fd63e1912beb85d2f (patch)
treea7a1936f2ff0764454cb0d86146d3182c2712425 /dev-python/pypax/pypax-0.4.0.ebuild
parentInitial ebuild by me. (diff)
downloadgentoo-2-b2a0dc38932ca8b86a64aa1fd63e1912beb85d2f.tar.gz
gentoo-2-b2a0dc38932ca8b86a64aa1fd63e1912beb85d2f.tar.bz2
gentoo-2-b2a0dc38932ca8b86a64aa1fd63e1912beb85d2f.zip
Version bump, makes XT_PAX support optional
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pypax/pypax-0.4.0.ebuild')
-rw-r--r--dev-python/pypax/pypax-0.4.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pypax/pypax-0.4.0.ebuild b/dev-python/pypax/pypax-0.4.0.ebuild
new file mode 100644
index 000000000000..306781397d62
--- /dev/null
+++ b/dev-python/pypax/pypax-0.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypax/pypax-0.4.0.ebuild,v 1.1 2011/11/27 02:33:28 blueness Exp $
+
+EAPI=3
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils
+
+DESCRIPTION="Python module for reading or writing PaX flags to an ELF."
+HOMEPAGE="http://dev.gentoo.org/~blueness/elfix/"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/elfix-${PV}.tar.gz"
+
+S="${WORKDIR}/elfix-${PV}/scripts"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="xtpax"
+
+DEPEND="dev-libs/elfutils
+ sys-devel/binutils
+ xtpax? ( sys-apps/attr )"
+RDEPEND=""
+
+src_compile() {
+ unset XATTR
+ use xtpax && export XATTR="yes"
+ distutils_src_compile
+}