summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-12-29 15:27:03 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-12-29 15:27:03 +0000
commit279bd775ea48f4fd736dacc97fc8b13fefb62615 (patch)
tree78dd06f89a3dbc5e2cae50a39310f50a557ae775 /dev-python/pypax
parentVersion bump wrt bug #449128. (diff)
downloadgentoo-2-279bd775ea48f4fd736dacc97fc8b13fefb62615.tar.gz
gentoo-2-279bd775ea48f4fd736dacc97fc8b13fefb62615.tar.bz2
gentoo-2-279bd775ea48f4fd736dacc97fc8b13fefb62615.zip
Version bump, use portage for link mappings in revdep-pax and migrate-pax
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-python/pypax')
-rw-r--r--dev-python/pypax/ChangeLog3
-rw-r--r--dev-python/pypax/pypax-0.8.0.ebuild36
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pypax/ChangeLog b/dev-python/pypax/ChangeLog
index a45a8779c7a1..35895e4a428e 100644
--- a/dev-python/pypax/ChangeLog
+++ b/dev-python/pypax/ChangeLog
@@ -1,3 +1,6 @@
+# ChangeLog for dev-python/pypax
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypax/ChangeLog,v 1.33 2012/12/29 15:27:03 blueness Exp $
29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> pypax-0.7.0.ebuild:
Stable for sparc, wrt bug #445334
diff --git a/dev-python/pypax/pypax-0.8.0.ebuild b/dev-python/pypax/pypax-0.8.0.ebuild
new file mode 100644
index 000000000000..7b5012b6a7ad
--- /dev/null
+++ b/dev-python/pypax/pypax-0.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypax/pypax-0.8.0.ebuild,v 1.1 2012/12/29 15:27:03 blueness Exp $
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils
+
+DESCRIPTION="Python module for reading or writing PaX flags to an ELF."
+HOMEPAGE="http://dev.gentoo.org/~blueness/elfix/
+ http://www.gentoo.org/proj/en/hardened/pax-quickstart.xml"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/elfix-${PV}.tar.gz"
+
+S="${WORKDIR}/elfix-${PV}/scripts"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+ptpax +xtpax"
+
+DEPEND="
+ dev-libs/elfutils
+ xtpax? ( sys-apps/attr )"
+
+RDEPEND=""
+
+src_compile() {
+ unset PTPAX
+ unset XTPAX
+ use ptpax && export PTPAX="yes"
+ use xtpax && export XTPAX="yes"
+ distutils_src_compile
+}