summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-06-24 07:44:40 +0000
committerIan Delaney <idella4@gentoo.org>2015-06-24 07:44:40 +0000
commitb421ac90e30be06db70bf3dbe0aa2a6fe666b375 (patch)
tree3e6991c4e9198db40675097f930daf8019d80228 /dev-python/pyproj
parentDrop base.eclass usage (diff)
downloadgentoo-2-b421ac90e30be06db70bf3dbe0aa2a6fe666b375.tar.gz
gentoo-2-b421ac90e30be06db70bf3dbe0aa2a6fe666b375.tar.bz2
gentoo-2-b421ac90e30be06db70bf3dbe0aa2a6fe666b375.zip
bump; New HOMEPAGE & SRC_URI due to shift of repo location of development, add test phase, closes Bug 552174
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyproj')
-rw-r--r--dev-python/pyproj/ChangeLog8
-rw-r--r--dev-python/pyproj/pyproj-1.9.4.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/pyproj/ChangeLog b/dev-python/pyproj/ChangeLog
index 8247f496f23d..eb23a9fa7757 100644
--- a/dev-python/pyproj/ChangeLog
+++ b/dev-python/pyproj/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyproj
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyproj/ChangeLog,v 1.12 2015/01/04 22:46:41 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyproj/ChangeLog,v 1.13 2015/06/24 07:44:40 idella4 Exp $
+
+*pyproj-1.9.4 (24 Jun 2015)
+
+ 24 Jun 2015; Ian Delaney <idella4@gentoo.org> +pyproj-1.9.4.ebuild:
+ bump; New HOMEPAGE & SRC_URI due to shift of repo location of development,
+ add test phase, closes Bug 552174
*pyproj-1.9.3-r1 (04 Jan 2015)
diff --git a/dev-python/pyproj/pyproj-1.9.4.ebuild b/dev-python/pyproj/pyproj-1.9.4.ebuild
new file mode 100644
index 000000000000..bb58454d27ab
--- /dev/null
+++ b/dev-python/pyproj/pyproj-1.9.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyproj/pyproj-1.9.4.ebuild,v 1.1 2015/06/24 07:44:40 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to PROJ.4 library"
+HOMEPAGE="http://github.com/jswhit/pyproj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="doc"
+
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+python_test() {
+ einfo "Testruns do not have regular unittest type tests, instead for test.py,"
+ einfo "the output need be compared with a separate file, sample.out."
+ "${PYTHON}" test/test.py || die
+
+ einfo ""; einfo "Now the file test2.py is run to test pickling"; einfo ""
+ "${PYTHON}" test/test2.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}