summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-12-05 16:02:22 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-12-05 16:02:22 +0000
commiteb276aae9990c5897ecc4d259f8ff0233a125840 (patch)
tree90cd8c0e9376cff9c7ae6c4bf3c7192334309d27 /dev-python/pyprotocols/pyprotocols-0.9.3.ebuild
parentMoved from net-misc/linesrv to net-dialup/linesrv. (diff)
downloadgentoo-2-eb276aae9990c5897ecc4d259f8ff0233a125840.tar.gz
gentoo-2-eb276aae9990c5897ecc4d259f8ff0233a125840.tar.bz2
gentoo-2-eb276aae9990c5897ecc4d259f8ff0233a125840.zip
Version bump.
Diffstat (limited to 'dev-python/pyprotocols/pyprotocols-0.9.3.ebuild')
-rw-r--r--dev-python/pyprotocols/pyprotocols-0.9.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyprotocols/pyprotocols-0.9.3.ebuild b/dev-python/pyprotocols/pyprotocols-0.9.3.ebuild
new file mode 100644
index 000000000000..97b4265877ca
--- /dev/null
+++ b/dev-python/pyprotocols/pyprotocols-0.9.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyprotocols/pyprotocols-0.9.3.ebuild,v 1.1 2004/12/05 16:02:22 kloeri Exp $
+
+inherit distutils
+
+MY_PF=${PF/pypro/PyPro}
+S=${WORKDIR}/${MY_PF}
+
+SRC_URI="http://peak.telecommunity.com/dist/${MY_PF}.tar.gz"
+DESCRIPTION="Adapter/protocol framework for Python"
+HOMEPAGE="http://peak.telecommunity.com/PyProtocols.html"
+LICENSE="ZPL"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="sys-devel/gcc
+ >=dev-lang/python-2.2"
+
+pkg_postinst() {
+ distutils_pkg_postinst
+}
+
+src_test() {
+ cd ${S}
+ python setup.py test || die "Unit tests failed!"
+}