summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2007-05-03 04:38:35 +0000
committerRob Cakebread <pythonhead@gentoo.org>2007-05-03 04:38:35 +0000
commite042fee4f8bbfa023ca4b900051f2a060668d4b2 (patch)
tree94202029bb116d0d8809d8b8a59bb9f8ab05e2bc /dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild
parentBring back 1.20 for sparc, rekeyword 1.21 as ~sparc (bug #176256). (diff)
downloadgentoo-2-e042fee4f8bbfa023ca4b900051f2a060668d4b2.tar.gz
gentoo-2-e042fee4f8bbfa023ca4b900051f2a060668d4b2.tar.bz2
gentoo-2-e042fee4f8bbfa023ca4b900051f2a060668d4b2.zip
Version bump snapshot required for turbogears-1.0.2.2. Dropped amd64 keyword because of new dep on decoratortools.
(Portage version: 2.1.2.5)
Diffstat (limited to 'dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild')
-rw-r--r--dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild b/dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild
new file mode 100644
index 000000000000..bb17cb160bf6
--- /dev/null
+++ b/dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild,v 1.1 2007/05/03 04:38:35 pythonhead Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+KEYWORDS="~x86"
+
+MY_PN=PyProtocols
+MY_P=${MY_PN}-${PV/_pre/a0dev_r}
+
+DESCRIPTION="Extends the PEP 246 adapt() function with a new 'declaration API' that lets you easily define your own protocols and adapters, and declare what adapters should be used to adapt what types, objects, or protocols."
+HOMEPAGE="http://peak.telecommunity.com/PyProtocols.html"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+LICENSE="|| ( PSF-2.4 ZPL )"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ app-arch/unzip
+ >=dev-python/decoratortools-1.4"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_PN}
+
+PYTHON_MODNAME="protocols"
+