summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-02-23 15:44:37 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-02-23 15:44:37 +0000
commitb892f4a229545db728179c128876b635eb24b786 (patch)
tree7af73ced06c324b0a2700b5e3eb4c822e5a303f5 /dev-python/pyqwt/pyqwt-4.2-r1.ebuild
parentMove x11-proto/* out of RDEPEND, bug 204781. mips ->~mips to fix deps. (diff)
downloadgentoo-2-b892f4a229545db728179c128876b635eb24b786.tar.gz
gentoo-2-b892f4a229545db728179c128876b635eb24b786.tar.bz2
gentoo-2-b892f4a229545db728179c128876b635eb24b786.zip
Fixed a couple of serious QA issues.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/pyqwt/pyqwt-4.2-r1.ebuild')
-rw-r--r--dev-python/pyqwt/pyqwt-4.2-r1.ebuild37
1 files changed, 22 insertions, 15 deletions
diff --git a/dev-python/pyqwt/pyqwt-4.2-r1.ebuild b/dev-python/pyqwt/pyqwt-4.2-r1.ebuild
index 6e5b04bd61ac..6bbdf0d65a1b 100644
--- a/dev-python/pyqwt/pyqwt-4.2-r1.ebuild
+++ b/dev-python/pyqwt/pyqwt-4.2-r1.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-4.2-r1.ebuild,v 1.2 2007/07/11 06:19:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-4.2-r1.ebuild,v 1.3 2008/02/23 15:44:37 dev-zero Exp $
-inherit distutils eutils
+NEED_PYTHON="2.3"
-MY_P=PyQwt-${PV}
-S=${WORKDIR}/${MY_P}
+inherit distutils eutils python
+
+MY_P="PyQwt-${PV}"
+S="${WORKDIR}/${MY_P}"
DESCRIPTION="Python bindings for the Qwt library"
SRC_URI="mirror://sourceforge/pyqwt/${MY_P}.tar.gz"
@@ -16,31 +18,36 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~ia64 ~x86"
IUSE="debug"
-DEPEND=">=dev-lang/python-2.3.2
- ~x11-libs/qwt-4.2.0
+
+RDEPEND="~x11-libs/qwt-4.2.0
>=dev-python/PyQt-3.14
- >=dev-python/sip-4.2
>=dev-python/numarray-1.1.1
>=dev-python/numeric-23.7"
+DEPEND="${RDEPEND}
+ >=dev-python/sip-4.2"
src_compile() {
- cd ${S}/sip
+ cd "${S}/sip"
sed -i s/"[[:space:]]*const QLabel \*titleLabel() const\;"// qwtplot.sip
sed -i s/"[[:space:]]*const QwtPlotCanvas \*canvas() const\;"// qwtplot.sip
- cd ${S}/configure
+ cd "${S}/configure"
local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -l /usr/$(get_libdir) \
-i /usr/include/qwt -v /usr/share/sip -x /usr/share/sip"
use debug && myconf="${myconf} -u"
has distcc ${FEATURES} || myconf="${myconf} -c"
- python configure.py ${myconf}
+
+ python_version
+ "${python}" configure.py ${myconf} || die "python configure.py failed"
emake || die "emake failed"
}
src_install() {
- cd ${S}
+ cd "${S}"
sed -i s/2,4,9/2,5,9/ setup.py
- python setup.py install --prefix=/usr --root=${D} || die "install failed"
+
+ python_version
+ "${python}" setup.py install --prefix=/usr --root="${D}" || die "install failed"
dodoc ANNOUNCEMENT-4.2.TXT AUTHORS COPYING* README THANKS
- use doc && mv ${D}/usr/share/doc/${MY_P}/* ${D}/usr/share/doc/${PF}
- rm -rf ${D}/usr/share/doc/${MY_P}
+ use doc && mv "${D}/usr/share/doc/${MY_P}"/* "${D}/usr/share/doc/${PF}"
+ rm -rf "${D}/usr/share/doc/${MY_P}"
}