summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-02-16 14:25:30 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-02-16 14:25:30 +0000
commit6b2db06d03eeb9955614006c7b9fae3a5f9178ec (patch)
tree4acc6a03fa4202714d9419a2e01700da0323afc9 /dev-python/pyro
parentOverride USE='png -zlib' (bug 454890) (diff)
downloadgentoo-2-6b2db06d03eeb9955614006c7b9fae3a5f9178ec.tar.gz
gentoo-2-6b2db06d03eeb9955614006c7b9fae3a5f9178ec.tar.bz2
gentoo-2-6b2db06d03eeb9955614006c7b9fae3a5f9178ec.zip
Removing 4.14 which couldn't be stabilized because of serious bugs.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'dev-python/pyro')
-rw-r--r--dev-python/pyro/ChangeLog5
-rw-r--r--dev-python/pyro/pyro-4.14.ebuild94
2 files changed, 4 insertions, 95 deletions
diff --git a/dev-python/pyro/ChangeLog b/dev-python/pyro/ChangeLog
index 58c35a6957cb..ccae165047f2 100644
--- a/dev-python/pyro/ChangeLog
+++ b/dev-python/pyro/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pyro
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.79 2013/02/03 17:55:25 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.80 2013/02/16 14:25:30 aidecoe Exp $
+
+ 16 Feb 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> -pyro-4.14.ebuild:
+ Removing 4.14 which couldn't be stabilized because of serious bugs.
03 Feb 2013; Agostino Sarubbo <ago@gentoo.org> pyro-4.17.ebuild:
Stable for ppc, wrt bug #455170
diff --git a/dev-python/pyro/pyro-4.14.ebuild b/dev-python/pyro/pyro-4.14.ebuild
deleted file mode 100644
index eb4260fbe3c0..000000000000
--- a/dev-python/pyro/pyro-4.14.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.14.ebuild,v 1.3 2013/02/02 15:22:00 aidecoe Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.[45]"
-
-inherit distutils
-
-MY_PN="Pyro4"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
-HOMEPAGE="http://www.xs4all.nl/~irmen/pyro/ http://pypi.python.org/pypi/Pyro4"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="!dev-python/pyro:0"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- test? (
- dev-python/coverage
- dev-python/nose
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="Pyro4"
-
-src_prepare() {
- distutils_src_prepare
-
- sed -e '/sys.path.insert/a sys.path.insert(1,"PyroTests")' -i tests/run_suite.py
-
- # Disable tests requiring network connection.
- sed \
- -e "s/testBCstart/_&/" \
- -e "s/testDaemonPyroObj/_&/" \
- -e "s/testLookupAndRegister/_&/" \
- -e "s/testMulti/_&/" \
- -e "s/testRefuseDottedNames/_&/" \
- -e "s/testResolve/_&/" \
- -e "s/testBCLookup/_&/" \
- -i tests/PyroTests/test_naming.py
- sed \
- -e "s/testOwnloopBasics/_&/" \
- -e "s/testStartNSfunc/_&/" \
- -i tests/PyroTests/test_naming2.py
-
- sed \
- -e "s/testServerConnections/_&/" \
- -e "s/testServerParallelism/_&/" \
- -i tests/PyroTests/test_server.py
-
- sed \
- -e "s/testBroadcast/_&/" \
- -e "s/testGetIP/_&/" \
- -i tests/PyroTests/test_socket.py
-}
-
-src_test() {
- cd tests
-
- testing() {
- "$(PYTHON)" run_suite.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "Installation of examples failed"
- fi
-}
-
-pkg_postinst() {
- ewarn "A temporary workaround for a thread pool scaling problem (lock-up)"
- ewarn "is in effect: the thread pool is fixed at THREADPOOL_MINTHREADS"
- ewarn "threads. THREADPOOL_MAXTHREADS can still be set but has no effect"
- ewarn "at the moment, until the thread pool implementation has been fixed."
-}