summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-28 15:44:12 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-28 15:44:12 +0000
commitcae2a0577679e344ff950dac314c1b27de220326 (patch)
treedfb7b36457f855d11eaaadc790efa7b1107e0257 /dev-python/pysvn
parentBump to 0.21.1, latest version; works with 0.8 as well (diff)
downloadgentoo-2-cae2a0577679e344ff950dac314c1b27de220326.tar.gz
gentoo-2-cae2a0577679e344ff950dac314c1b27de220326.tar.bz2
gentoo-2-cae2a0577679e344ff950dac314c1b27de220326.zip
Version bump.
(Portage version: 15214-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pysvn')
-rw-r--r--dev-python/pysvn/ChangeLog10
-rw-r--r--dev-python/pysvn/pysvn-1.7.2.ebuild100
2 files changed, 108 insertions, 2 deletions
diff --git a/dev-python/pysvn/ChangeLog b/dev-python/pysvn/ChangeLog
index 66c95af86b29..5df2559b974f 100644
--- a/dev-python/pysvn/ChangeLog
+++ b/dev-python/pysvn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pysvn
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.6 2009/11/07 20:10:08 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.7 2010/01/28 15:44:12 arfrever Exp $
+
+*pysvn-1.7.2 (28 Jan 2010)
+
+ 28 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pysvn-1.7.2.ebuild:
+ Version bump.
07 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pysvn-1.7.1.ebuild:
diff --git a/dev-python/pysvn/pysvn-1.7.2.ebuild b/dev-python/pysvn/pysvn-1.7.2.ebuild
new file mode 100644
index 000000000000..115ca7cd2893
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.7.2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.2.ebuild,v 1.1 2010/01/28 15:44:12 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils multilib python toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="http://pysvn.tigris.org/"
+SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-freebsd ~ppc-macos"
+IUSE="doc examples"
+
+DEPEND="dev-util/subversion
+ >=dev-python/pycxx-5.5.0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Skip test test-06 if executed as root to avoid failure.
+ epatch "${FILESDIR}/${PN}-1.7.1-skip_root_test.patch"
+
+ # Don't use internal copy of dev-python/pycxx.
+ rm -fr Import
+
+ python_copy_sources --no-link
+
+ preparation() {
+ cd Source
+ if has "${PYTHON_ABI}" 2.4 2.5; then
+ "$(PYTHON)" setup.py backport || die "Backport failed"
+ fi
+ }
+ python_execute_function -s preparation
+}
+
+src_configure() {
+ configuration() {
+ cd Source
+ "$(PYTHON)" setup.py configure --apr-inc-dir="${EPREFIX}/usr/include/apr-1" --svn-root-dir="${EPREFIX}/usr" || die "Configuration failed with Python {PYTHON_ABI}"
+
+ sed -e 's:^\(CCFLAGS=\)\(.*\):\1$(CFLAGS) \2:g' \
+ -e 's:^\(CCCFLAGS=\)\(.*\):\1$(CXXFLAGS) \2:g' \
+ -e "/^CCC=/s:g++:$(tc-getCXX):" \
+ -e "/^CC=/s:gcc:$(tc-getCC):" \
+ -e "/^LDSHARED=/s:g++:$(tc-getCXX):" \
+ -i Makefile \
+ || die "sed failed in Makefile"
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ building() {
+ cd Source
+ emake
+ }
+ python_execute_function -s building
+}
+
+src_test() {
+ testing() {
+ cd Source
+ emake test || die "test-pysvn.so failed with Python ${PYTHON_ABI}"
+ emake -C ../Tests || die "Tests failed with Python ${PYTHON_ABI}"
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ installation() {
+ cd Source/pysvn
+ exeinto "$(python_get_sitedir)/pysvn"
+ doexe _pysvn*$(get_modname) || die "doexe failed"
+ insinto "$(python_get_sitedir)/pysvn"
+ doins __init__.py || die "doins failed"
+ }
+ python_execute_function -s installation
+
+ if use doc; then
+ dohtml -r Docs/ || die "dohtml failed"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc Examples/Client/* || die "dodoc examples failed"
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize pysvn
+}
+
+pkg_postrm() {
+ python_mod_cleanup pysvn
+}