summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-09-17 07:21:57 +0000
committerJustin Lecher <jlec@gentoo.org>2014-09-17 07:21:57 +0000
commitd3652775a9b2b7627a04087baa13307103db5cfc (patch)
tree759646f5336f3a2b90c01dfa0d23c242bd124831 /dev-python/pytables
parentFix last commit to account for PYTHON_TARGETS. (diff)
downloadgentoo-2-d3652775a9b2b7627a04087baa13307103db5cfc.tar.gz
gentoo-2-d3652775a9b2b7627a04087baa13307103db5cfc.tar.bz2
gentoo-2-d3652775a9b2b7627a04087baa13307103db5cfc.zip
dev-python/pytables: Add backport patch for >cython-0.20
(Portage version: 2.2.13/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/pytables')
-rw-r--r--dev-python/pytables/ChangeLog6
-rw-r--r--dev-python/pytables/files/pytables-3.1.1-cython-backport.patch65
-rw-r--r--dev-python/pytables/metadata.xml18
-rw-r--r--dev-python/pytables/pytables-3.1.1.ebuild8
4 files changed, 85 insertions, 12 deletions
diff --git a/dev-python/pytables/ChangeLog b/dev-python/pytables/ChangeLog
index 9bb83022868a..d001db02b252 100644
--- a/dev-python/pytables/ChangeLog
+++ b/dev-python/pytables/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pytables
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/ChangeLog,v 1.52 2014/06/21 15:17:30 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/ChangeLog,v 1.53 2014/09/17 07:21:57 jlec Exp $
+
+ 17 Sep 2014; Justin Lecher <jlec@gentoo.org> pytables-3.1.1.ebuild,
+ +files/pytables-3.1.1-cython-backport.patch, metadata.xml:
+ Add backport patch for >cython-0.20
21 Jun 2014; Ian Delaney <idella4@gentoo.org> pytables-3.1.1.ebuild:
drop py2.6 add py3.4 support
diff --git a/dev-python/pytables/files/pytables-3.1.1-cython-backport.patch b/dev-python/pytables/files/pytables-3.1.1-cython-backport.patch
new file mode 100644
index 000000000000..7db41d2e1a62
--- /dev/null
+++ b/dev-python/pytables/files/pytables-3.1.1-cython-backport.patch
@@ -0,0 +1,65 @@
+ setup.py | 13 +++++++------
+ tables/req_versions.py | 2 +-
+ 2 files changed, 8 insertions(+), 7 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 0f2f3f7..52cda49 100755
+--- a/setup.py
++++ b/setup.py
+@@ -25,6 +25,7 @@ from distutils.core import Extension
+ from distutils.dep_util import newer
+ from distutils.util import convert_path
+ from distutils.ccompiler import new_compiler
++from distutils.version import LooseVersion
+
+ cmdclass = {}
+ setuptools_kwargs = {}
+@@ -106,7 +107,7 @@ def check_import(pkgname, pkgver):
+ "You need %(pkgname)s %(pkgver)s or greater to run PyTables!"
+ % {'pkgname': pkgname, 'pkgver': pkgver})
+ else:
+- if mod.__version__ < pkgver:
++ if mod.__version__ < LooseVersion(pkgver):
+ exit_with_error(
+ "You need %(pkgname)s %(pkgver)s or greater to run PyTables!"
+ % {'pkgname': pkgname, 'pkgver': pkgver})
+@@ -122,21 +123,21 @@ if not has_setuptools:
+
+ # Check if Cython is installed or not (requisite)
+ try:
++ from Cython import __version__ as cython_version
+ from Cython.Distutils import build_ext
+- from Cython.Compiler.Main import Version
+ cmdclass['build_ext'] = build_ext
+ except ImportError:
+ exit_with_error(
+ "You need %(pkgname)s %(pkgver)s or greater to compile PyTables!"
+ % {'pkgname': 'Cython', 'pkgver': min_cython_version})
+
+-if Version.version < min_cython_version:
++if LooseVersion(cython_version) < min_cython_version:
+ exit_with_error(
+- "At least Cython %s is needed so as to generate extensions!"
+- % (min_cython_version))
++ "You need %(pkgname)s %(pkgver)s or greater to run PyTables!"
++ % {'pkgname': 'Cython', 'pkgver': min_cython_version})
+ else:
+ print("* Found %(pkgname)s %(pkgver)s package installed."
+- % {'pkgname': 'Cython', 'pkgver': Version.version})
++ % {'pkgname': 'Cython', 'pkgver': cython_version})
+
+ VERSION = open('VERSION').read().strip()
+
+diff --git a/tables/req_versions.py b/tables/req_versions.py
+index 2c9ca01..bd498c3 100644
+--- a/tables/req_versions.py
++++ b/tables/req_versions.py
+@@ -17,7 +17,7 @@
+ # Minimum recommended versions for mandatory packages
+ min_numpy_version = '1.4.1'
+ min_numexpr_version = '2.0.0'
+-min_cython_version = '0.13'
++min_cython_version = '0.14'
+
+ # The THG team has decided to fix an API inconsistency in the definition
+ # of the H5Z_class_t structure in version 1.8.3
diff --git a/dev-python/pytables/metadata.xml b/dev-python/pytables/metadata.xml
index d6c7d73ea719..eef5dfdbc35f 100644
--- a/dev-python/pytables/metadata.xml
+++ b/dev-python/pytables/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>python</herd>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>python</herd>
+ <herd>sci</herd>
+ <longdescription lang="en">
PyTables is a hierarchical database package designed to efficently
manage very large amounts of data. PyTables is built on top of the
HDF5 library and the NumPy package. It features an object-oriented
@@ -11,10 +11,10 @@
from Pyrex sources, makes it a fast, yet extremely easy to use tool
for interactively save and retrieve large amounts of data.
</longdescription>
-<use>
- <flag name="contrib">Install user-contributed files</flag>
-</use>
-<upstream>
- <remote-id type="pypi">tables</remote-id>
-</upstream>
+ <use>
+ <flag name="contrib">Install user-contributed files</flag>
+ </use>
+ <upstream>
+ <remote-id type="pypi">tables</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/pytables/pytables-3.1.1.ebuild b/dev-python/pytables/pytables-3.1.1.ebuild
index 8724daa17379..46eaa552488b 100644
--- a/dev-python/pytables/pytables-3.1.1.ebuild
+++ b/dev-python/pytables/pytables-3.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-3.1.1.ebuild,v 1.2 2014/06/21 15:17:30 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-3.1.1.ebuild,v 1.3 2014/09/17 07:21:57 jlec Exp $
EAPI=5
@@ -30,12 +30,16 @@ RDEPEND="
dev-python/numexpr[${PYTHON_USEDEP}]
sci-libs/hdf5:0="
DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]"
+ >=dev-python/cython-0.14[${PYTHON_USEDEP}]"
S="${WORKDIR}/${MY_P}"
DOCS=( ANNOUNCE.txt RELEASE_NOTES.txt THANKS )
+PATCHES=(
+ "${FILESDIR}"/${P}-cython-backport.patch
+ )
+
python_prepare_all() {
export HDF5_DIR="${EPREFIX}"/usr
sed -i -e "s:/usr:${EPREFIX}/usr:g" setup.py || die