summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-22 15:38:50 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-22 15:38:50 +0000
commitd398b1e59a90a23bdf17bf622c8be413076424eb (patch)
tree56e2ffeebbf0826e70450a4df436f490e1a4b0de /dev-python/python-biggles
parentMask net-wireless/gnome-bluetooth:0 and net-wireless/libbtctl for removal (diff)
downloadgentoo-2-d398b1e59a90a23bdf17bf622c8be413076424eb.tar.gz
gentoo-2-d398b1e59a90a23bdf17bf622c8be413076424eb.tar.bz2
gentoo-2-d398b1e59a90a23bdf17bf622c8be413076424eb.zip
Delete older ebuilds.
(Portage version: 2.2_rc86_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-biggles')
-rw-r--r--dev-python/python-biggles/ChangeLog7
-rw-r--r--dev-python/python-biggles/files/python-biggles-1.6.4-numpy.patch468
-rw-r--r--dev-python/python-biggles/python-biggles-1.6.4-r1.ebuild53
-rw-r--r--dev-python/python-biggles/python-biggles-1.6.5.ebuild34
4 files changed, 6 insertions, 556 deletions
diff --git a/dev-python/python-biggles/ChangeLog b/dev-python/python-biggles/ChangeLog
index 91efac2f98f9..e04b439d7897 100644
--- a/dev-python/python-biggles/ChangeLog
+++ b/dev-python/python-biggles/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-biggles
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/ChangeLog,v 1.19 2010/09/21 20:26:16 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/ChangeLog,v 1.20 2010/09/22 15:38:49 arfrever Exp $
+
+ 22 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -python-biggles-1.6.4-r1.ebuild, -files/python-biggles-1.6.4-numpy.patch,
+ -python-biggles-1.6.5.ebuild:
+ Delete.
21 Sep 2010; Markos Chandras <hwoarang@gentoo.org>
python-biggles-1.6.6.ebuild:
diff --git a/dev-python/python-biggles/files/python-biggles-1.6.4-numpy.patch b/dev-python/python-biggles/files/python-biggles-1.6.4-numpy.patch
deleted file mode 100644
index 110d4db8c373..000000000000
--- a/dev-python/python-biggles/files/python-biggles-1.6.4-numpy.patch
+++ /dev/null
@@ -1,468 +0,0 @@
-diff -ur python2-biggles-1.6.4/examples/example1.py python2-biggles-1.6.4_numpy/examples/example1.py
---- python2-biggles-1.6.4/examples/example1.py 2001-03-30 03:32:20.000000000 +0300
-+++ python2-biggles-1.6.4_numpy/examples/example1.py 2007-07-21 18:48:59.000000000 +0300
-@@ -4,11 +4,11 @@
- sys.path.insert(1,'..')
-
- import biggles
--import Numeric, math
-+import numpy, math
-
--x = Numeric.arange( 0, 3*math.pi, math.pi/30 )
--c = Numeric.cos(x)
--s = Numeric.sin(x)
-+x = numpy.arange( 0, 3*math.pi, math.pi/30 )
-+c = numpy.cos(x)
-+s = numpy.sin(x)
-
- p = biggles.FramedPlot()
- p.title = "title"
-diff -ur python2-biggles-1.6.4/examples/example2.py python2-biggles-1.6.4_numpy/examples/example2.py
---- python2-biggles-1.6.4/examples/example2.py 2001-03-30 03:32:20.000000000 +0300
-+++ python2-biggles-1.6.4_numpy/examples/example2.py 2007-07-21 18:48:59.000000000 +0300
-@@ -4,16 +4,17 @@
- sys.path.insert(1,'..')
-
- import biggles
--import Numeric, RandomArray
-+import numpy
-+import numpy.random
-
- p = biggles.FramedPlot()
- p.xrange = 0, 100
- p.yrange = 0, 100
- p.aspect_ratio = 1
-
--x = Numeric.arange( 0, 100, 5 )
--yA = RandomArray.normal( 40, 10, (len(x),) )
--yB = x + RandomArray.normal( 0, 5, (len(x),) )
-+x = numpy.arange( 0, 100, 5 )
-+yA = numpy.random.normal( 40, 10, (len(x),) )
-+yB = x + numpy.random.normal( 0, 5, (len(x),) )
-
- a = biggles.Points( x, yA, type="circle" )
- a.label = "a points"
-diff -ur python2-biggles-1.6.4/examples/example3.py python2-biggles-1.6.4_numpy/examples/example3.py
---- python2-biggles-1.6.4/examples/example3.py 2001-03-30 03:32:20.000000000 +0300
-+++ python2-biggles-1.6.4_numpy/examples/example3.py 2007-07-21 18:48:59.000000000 +0300
-@@ -4,10 +4,10 @@
- sys.path.insert(1,'..')
-
- import biggles
--import math, Numeric
-+import math, numpy
-
--x = Numeric.arange( 0, 3*math.pi, math.pi/10 )
--y = Numeric.sin(x)
-+x = numpy.arange( 0, 3*math.pi, math.pi/10 )
-+y = numpy.sin(x)
-
- p = biggles.FramedPlot()
- p.title = "Title"
-diff -ur python2-biggles-1.6.4/examples/example4.py python2-biggles-1.6.4_numpy/examples/example4.py
---- python2-biggles-1.6.4/examples/example4.py 2001-03-30 03:32:20.000000000 +0300
-+++ python2-biggles-1.6.4_numpy/examples/example4.py 2007-07-21 18:48:59.000000000 +0300
-@@ -4,11 +4,11 @@
- sys.path.insert(1,'..')
-
- import biggles
--import math, Numeric
-+import math, numpy
-
--x = Numeric.arange( 0, 2*math.pi, math.pi/20 )
--s = Numeric.sin(x)
--c = Numeric.cos(x)
-+x = numpy.arange( 0, 2*math.pi, math.pi/20 )
-+s = numpy.sin(x)
-+c = numpy.cos(x)
-
- inset = biggles.FramedPlot()
- inset.title = "inset"
-diff -ur python2-biggles-1.6.4/examples/example5.py python2-biggles-1.6.4_numpy/examples/example5.py
---- python2-biggles-1.6.4/examples/example5.py 2001-03-30 03:32:20.000000000 +0300
-+++ python2-biggles-1.6.4_numpy/examples/example5.py 2007-07-21 18:48:59.000000000 +0300
-@@ -4,10 +4,10 @@
- sys.path.insert(1,'..')
-
- import biggles
--import math, Numeric
-+import math, numpy
-
--x = Numeric.arange( 0, 3*math.pi, math.pi/10 )
--y = Numeric.sin(x)
-+x = numpy.arange( 0, 3*math.pi, math.pi/10 )
-+y = numpy.sin(x)
-
- a = biggles.FramedArray( 2, 2, title='title' )
- a.aspect_ratio = 0.75
-diff -ur python2-biggles-1.6.4/examples/example6.py python2-biggles-1.6.4_numpy/examples/example6.py
---- python2-biggles-1.6.4/examples/example6.py 2001-04-01 00:20:11.000000000 +0300
-+++ python2-biggles-1.6.4_numpy/examples/example6.py 2007-07-21 18:48:59.000000000 +0300
-@@ -4,11 +4,11 @@
- sys.path.insert(1,'..')
-
- import biggles
--import Numeric, math
-+import numpy, math
-
--x = Numeric.arange( 1*math.pi, 3*math.pi, math.pi/30 )
--c = Numeric.cos(x)
--s = Numeric.sin(x)
-+x = numpy.arange( 1*math.pi, 3*math.pi, math.pi/30 )
-+c = numpy.cos(x)
-+s = numpy.sin(x)
-
- p = biggles.FramedPlot()
- p.aspect_ratio = 1
-diff -ur python2-biggles-1.6.4/examples/example8.py python2-biggles-1.6.4_numpy/examples/example8.py
---- python2-biggles-1.6.4/examples/example8.py 2004-03-08 06:41:46.000000000 +0200
-+++ python2-biggles-1.6.4_numpy/examples/example8.py 2007-07-21 18:48:59.000000000 +0300
-@@ -4,22 +4,22 @@
- sys.path.insert(1,'..')
-
- import biggles
--import Numeric
-+import numpy
-
- #
- # Create example 2-dimensional data set of two solitons colliding.
- #
- n = 64
--x = Numeric.arange( -10., 10., 20./n )
--t = Numeric.arange( -1., 1., 2./n )
--z = Numeric.zeros( (len(x),len(t)), Numeric.Float )
-+x = numpy.arange( -10., 10., 20./n )
-+t = numpy.arange( -1., 1., 2./n )
-+z = numpy.zeros( (len(x),len(t)) )
-
- for i in range(len(x)):
- for j in range(len(t)):
-- z[i,j] = -12. * (3. + 4.*Numeric.cosh(2.*x[i]-8.*t[j]) \
-- + Numeric.cosh(4.*x[i] - 64.*t[j])) / \
-- (3.*Numeric.cosh(x[i]-28.*t[j]) \
-- + Numeric.cosh(3.*x[i]-36.*t[j]))**2
-+ z[i,j] = -12. * (3. + 4.*numpy.cosh(2.*x[i]-8.*t[j]) \
-+ + numpy.cosh(4.*x[i] - 64.*t[j])) / \
-+ (3.*numpy.cosh(x[i]-28.*t[j]) \
-+ + numpy.cosh(3.*x[i]-36.*t[j]))**2
-
- #
- # Make contour component.
-diff -ur python2-biggles-1.6.4/examples/example9.py python2-biggles-1.6.4_numpy/examples/example9.py
---- python2-biggles-1.6.4/examples/example9.py 2004-03-09 01:07:44.000000000 +0200
-+++ python2-biggles-1.6.4_numpy/examples/example9.py 2007-07-21 18:48:59.000000000 +0300
-@@ -4,7 +4,7 @@
- sys.path.insert(1,'..')
-
- import biggles
--from Numeric import *
-+from numpy import *
-
- def mag( vec ):
- return sqrt(sum(vec*vec, -1))
-@@ -17,7 +17,7 @@
- # Let's color the points by their distance from the point (3,7)
- center = (3,7)
- rad = mag( transpose([x,y]) - center )
-- scaledrad = (1 - rad/max(rad))[:,NewAxis]
-+ scaledrad = (1 - rad/max(rad))[:,newaxis]
-
- # Go from light blue to intense red.
- minColor = array([0.6, 0.9, 1.0])
-diff -ur python2-biggles-1.6.4/examples/example-matlab.py python2-biggles-1.6.4_numpy/examples/example-matlab.py
---- python2-biggles-1.6.4/examples/example-matlab.py 2004-03-09 00:57:09.000000000 +0200
-+++ python2-biggles-1.6.4_numpy/examples/example-matlab.py 2007-07-21 18:48:59.000000000 +0300
-@@ -4,14 +4,14 @@
- sys.path.insert(1,'..')
- sys.ps1 = None
-
--import Numeric
-+import numpy
- from biggles.matlab import *
-
- def press_return():
- print "[press return]"
- sys.stdin.readline()
-
--x = Numeric.arrayrange(-10,10);
-+x = numpy.arange(-10,10);
- y = x**2;
- e = y/4
-
-diff -ur python2-biggles-1.6.4/make.inc python2-biggles-1.6.4_numpy/make.inc
---- python2-biggles-1.6.4/make.inc 2004-03-09 00:43:12.000000000 +0200
-+++ python2-biggles-1.6.4_numpy/make.inc 2007-07-21 18:48:59.000000000 +0300
-@@ -28,11 +28,11 @@
-
- LIBPLOT_PREFIX = /usr/local
- LIBPLOT_CPPFLAGS = -I$(LIBPLOT_PREFIX)/include
--LIBPLOT_LDFLAGS = -L$(LIBPLOT_PREFIX)/lib -lplot \
-- -L/usr/X11R6/lib -lXaw -lXmu -lXt -lSM -lICE -lXext -lX11
-+LIBPLOT_LDFLAGS = -L$(LIBPLOT_PREFIX)/lib64 -L$(LIBPLOT_PREFIX)/lib \
-+ -lplot -L/usr/X11R6/lib64 -L/usr/X11R6/lib \
-+ -lXaw -lXmu -lXt -lSM -lICE -lXext -lX11
-
--## uncomment this line if there isn't a Numeric include subdirectory
--#NUMERIC_CPPFLAGS = -DNO_NUMERIC_INCDIR
-+NUMPY_CPPFLAGS = -I$(shell $(PYTHON) -c 'import numpy; print numpy.get_include()')
-
- ## these options probably don't need to be changed
-
-diff -ur python2-biggles-1.6.4/setup.py python2-biggles-1.6.4_numpy/setup.py
---- python2-biggles-1.6.4/setup.py 2004-03-09 01:40:25.000000000 +0200
-+++ python2-biggles-1.6.4_numpy/setup.py 2007-07-21 18:48:59.000000000 +0300
-@@ -33,16 +33,26 @@
- from distutils.sysconfig import get_python_inc
- import sys
-
--## libplot
-+import numpy
-+numpy_include_dirs = numpy.get_include()
-+
-+## _biggles module
-+
-+_biggles_include_dirs = [ numpy_include_dirs ]
-+
-+## libplot module
-
- if sys.platform == "win32":
- libplot_include_dirs = []
- libplot_library_dirs = []
- libplot_libraries = ["plot.dll"]
- else:
-- libplot_prefix = "/usr/local"
-- libplot_include_dirs = [libplot_prefix+"/include"]
-- libplot_library_dirs = [libplot_prefix+"/lib", "/usr/X11R6/lib"]
-+ #libplot_prefix = "/u/mrnolta/local"
-+ #libplot_include_dirs = [libplot_prefix+"/include", numpy_include_dirs]
-+ #libplot_library_dirs = [libplot_prefix+"/lib64",libplot_prefix+"/lib",
-+ # "/usr/X11R6/lib64","/usr/X11R6/lib"]
-+ libplot_include_dirs = [numpy_include_dirs]
-+ libplot_library_dirs = ["/usr/X11R6/lib64","/usr/X11R6/lib"]
- libplot_libraries = ["plot","Xaw","Xmu","Xt","SM","ICE","Xext","X11"]
-
- # own install_data class to allow installation of data file
-@@ -83,7 +93,9 @@
-
- ext_package = "biggles",
- ext_modules = [
-- Extension( "_biggles", ["src/_biggles.c"] ),
-+ Extension( "_biggles",
-+ ["src/_biggles.c"],
-+ include_dirs = _biggles_include_dirs ),
-
- Extension( "libplot.libplot",
- ["src/libplot/libplot.c"],
-diff -ur python2-biggles-1.6.4/src/_biggles.c python2-biggles-1.6.4_numpy/src/_biggles.c
---- python2-biggles-1.6.4/src/_biggles.c 2003-01-19 04:30:04.000000000 +0200
-+++ python2-biggles-1.6.4_numpy/src/_biggles.c 2007-07-21 18:48:59.000000000 +0300
-@@ -22,12 +22,7 @@
-
- #include <Python.h>
- #include <math.h>
--
--#ifdef NO_NUMERIC_INCDIR
--#include <arrayobject.h>
--#else
--#include <Numeric/arrayobject.h>
--#endif
-+#include <numpy/arrayobject.h>
-
- #ifndef M_PI
- #define M_PI 3.14159265358979323846
-diff -ur python2-biggles-1.6.4/src/biggles.py python2-biggles-1.6.4_numpy/src/biggles.py
---- python2-biggles-1.6.4/src/biggles.py 2003-05-13 01:14:41.000000000 +0300
-+++ python2-biggles-1.6.4_numpy/src/biggles.py 2007-07-21 18:48:59.000000000 +0300
-@@ -20,7 +20,7 @@
- #
-
- import copy, math, os, string
--import Numeric
-+import numpy
-
- import config, _biggles
- from geometry import *
-@@ -102,7 +102,7 @@
- class _PlotGeometry:
-
- _logfunc = math.log10
-- _logfunc_vec = Numeric.log10
-+ _logfunc_vec = numpy.log10
-
- def __init__( self, src, dest, xlog=0, ylog=0 ):
- self.src_bbox = src
-@@ -127,8 +127,8 @@
- return self.aff( u, v )
-
- def call_vec( self, x, y ):
-- u = Numeric.asarray( x )
-- v = Numeric.asarray( y )
-+ u = numpy.asarray( x )
-+ v = numpy.asarray( y )
- if self.xlog: u = self._logfunc_vec(u)
- if self.ylog: v = self._logfunc_vec(v)
- return self.aff.call_vec( u, v )
-@@ -506,7 +506,7 @@
- return apply( BoundingBox, self.extent )
-
- def draw( self, context ):
-- #from Numeric import rank
-+ #from numpy import rank
- #if rank(self.densgrid) == 3:
- if len(self.densgrid.shape) == 3:
- context.draw.color_density_plot( self.densgrid, self.extent )
-diff -ur python2-biggles-1.6.4/src/contour.py python2-biggles-1.6.4_numpy/src/contour.py
---- python2-biggles-1.6.4/src/contour.py 2004-03-08 06:30:06.000000000 +0200
-+++ python2-biggles-1.6.4_numpy/src/contour.py 2007-07-21 18:48:59.000000000 +0300
-@@ -25,10 +25,10 @@
- from geometry import *
- import _biggles
-
--import Numeric
-+import numpy
-
- def _span( a, b, n ):
-- return a + float(b - a)*Numeric.arange( 0, n, 1, Numeric.Float )/(n-1)
-+ return a + float(b - a)*numpy.arange( 0, n, 1, numpy.Float )/(n-1)
-
- def _pop2( x, i, j ):
- if i < j:
-diff -ur python2-biggles-1.6.4/src/func.py python2-biggles-1.6.4_numpy/src/func.py
---- python2-biggles-1.6.4/src/func.py 2002-01-25 00:07:10.000000000 +0200
-+++ python2-biggles-1.6.4_numpy/src/func.py 2007-07-21 18:48:59.000000000 +0300
-@@ -52,8 +52,8 @@
- x.append( column[num] )
- x = map( atox, x )
- if return_numpy:
-- import Numeric
-- return Numeric.array( x )
-+ import numpy
-+ return numpy.array( x )
- return x
-
- def read_rows( filename, atox=float, comment_char=None, return_numpy=None ):
-@@ -63,7 +63,7 @@
- if return_numpy is None:
- return_numpy = config.value('read_rows','return_numpy')
- if return_numpy:
-- import Numeric
-+ import numpy
- x = []
- f = open( filename )
- lines = map( string.strip, f.readlines() )
-@@ -74,7 +74,7 @@
- continue
- row = map( atox, string.split(line) )
- if return_numpy:
-- row = Numeric.array( row )
-+ row = numpy.array( row )
- x.append( row )
- return x
-
-@@ -86,7 +86,7 @@
- m = read_rows( filename, atox=atox, comment_char=comment_char, \
- return_numpy=0 )
- if return_numpy:
-- import Numeric
-- return Numeric.array( m )
-+ import numpy
-+ return numpy.array( m )
- return m
-
-diff -ur python2-biggles-1.6.4/src/geometry.py python2-biggles-1.6.4_numpy/src/geometry.py
---- python2-biggles-1.6.4/src/geometry.py 2003-05-13 01:13:11.000000000 +0300
-+++ python2-biggles-1.6.4_numpy/src/geometry.py 2007-07-21 18:48:59.000000000 +0300
-@@ -19,7 +19,7 @@
- # Boston, MA 02111-1307, USA.
- #
-
--import math, Numeric
-+import math, numpy
-
- # pt_* functions --------------------------------------------------------------
-
-@@ -213,8 +213,8 @@
- return p, q
-
- def call_vec( self, x, y ):
-- x_ = Numeric.asarray( x )
-- y_ = Numeric.asarray( y )
-+ x_ = numpy.asarray( x )
-+ y_ = numpy.asarray( y )
- p = self.t[0] + self.m[0][0] * x_ + self.m[0][1] * y_
- q = self.t[1] + self.m[1][0] * x_ + self.m[1][1] * y_
- return p, q
-diff -ur python2-biggles-1.6.4/src/libplot/libplot.c python2-biggles-1.6.4_numpy/src/libplot/libplot.c
---- python2-biggles-1.6.4/src/libplot/libplot.c 2003-05-12 23:57:55.000000000 +0300
-+++ python2-biggles-1.6.4_numpy/src/libplot/libplot.c 2007-07-21 18:48:59.000000000 +0300
-@@ -24,11 +24,7 @@
- #include <math.h>
- #include <plot.h>
-
--#ifdef NO_NUMERIC_INCDIR
--#include <arrayobject.h>
--#else
--#include <Numeric/arrayobject.h>
--#endif
-+#include <numpy/arrayobject.h>
-
- typedef int bool_t;
- #define TRUE 1
-diff -ur python2-biggles-1.6.4/src/libplot/Makefile python2-biggles-1.6.4_numpy/src/libplot/Makefile
---- python2-biggles-1.6.4/src/libplot/Makefile 2001-10-31 04:24:30.000000000 +0200
-+++ python2-biggles-1.6.4_numpy/src/libplot/Makefile 2007-07-21 18:48:59.000000000 +0300
-@@ -21,7 +21,7 @@
-
- include ../../make.inc
-
--CPPFLAGS = $(BASE_CPPFLAGS) $(NUMERIC_CPPFLAGS) $(LIBPLOT_CPPFLAGS)
-+CPPFLAGS = $(BASE_CPPFLAGS) $(NUMPY_CPPFLAGS) $(LIBPLOT_CPPFLAGS)
- LDFLAGS = $(BASE_LDFLAGS) $(LIBPLOT_LDFLAGS)
- TARGETS = libplot.so
-
-diff -ur python2-biggles-1.6.4/src/Makefile python2-biggles-1.6.4_numpy/src/Makefile
---- python2-biggles-1.6.4/src/Makefile 2001-10-31 04:24:30.000000000 +0200
-+++ python2-biggles-1.6.4_numpy/src/Makefile 2007-07-21 18:48:59.000000000 +0300
-@@ -21,7 +21,7 @@
-
- include ../make.inc
-
--CPPFLAGS = $(BASE_CPPFLAGS) $(NUMERIC_CPPFLAGS)
-+CPPFLAGS = $(BASE_CPPFLAGS) $(NUMPY_CPPFLAGS)
- LDFLAGS = $(BASE_LDFLAGS)
- TARGETS = _biggles.so
-
-diff -ur python2-biggles-1.6.4/src/matlab.py python2-biggles-1.6.4_numpy/src/matlab.py
---- python2-biggles-1.6.4/src/matlab.py 2001-11-16 06:19:21.000000000 +0200
-+++ python2-biggles-1.6.4_numpy/src/matlab.py 2007-07-21 18:48:59.000000000 +0300
-@@ -41,7 +41,7 @@
-
- import biggles
- import math
--import Numeric
-+import numpy
- import string
-
- class _MatlabEmulation:
-@@ -228,8 +228,8 @@
- if vmax is None:
- vmax = float(max(v))
- binwidth = (vmax - vmin) / float(nbins-1)
-- x = Numeric.arrayrange( vmin, vmax+binwidth, binwidth )
-- y = Numeric.zeros( x.shape, 'i' )
-+ x = numpy.arrayrange( vmin, vmax+binwidth, binwidth )
-+ y = numpy.zeros( x.shape, int )
-
- for i in range(len(v)):
- n = int(round((float(v[i]) - vmin) / binwidth, 0))
-@@ -238,8 +238,8 @@
- except IndexError:
- pass
-
-- xx = Numeric.zeros( 2*len(x) + 3, 'f' )
-- yy = Numeric.zeros( 2*len(y) + 3 )
-+ xx = numpy.zeros( 2*len(x) + 3 )
-+ yy = numpy.zeros( 2*len(y) + 3 )
- xx[0] = x[0]
- yy[0] = 0
-
diff --git a/dev-python/python-biggles/python-biggles-1.6.4-r1.ebuild b/dev-python/python-biggles/python-biggles-1.6.4-r1.ebuild
deleted file mode 100644
index ff8757f72ab6..000000000000
--- a/dev-python/python-biggles/python-biggles-1.6.4-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/python-biggles-1.6.4-r1.ebuild,v 1.6 2009/07/14 21:08:28 fauli Exp $
-
-inherit distutils eutils
-
-MY_P=${P/python/python2}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A Python module for creating publication-quality 2D scientific plots."
-SRC_URI="mirror://sourceforge/biggles/${MY_P}.tar.gz"
-HOMEPAGE="http://biggles.sourceforge.net/"
-
-DEPEND="media-libs/plotutils
- dev-python/numpy
- x11-libs/libSM
- x11-libs/libXext"
-RDEPEND="${DEPEND}"
-
-IUSE=""
-SLOT="0"
-KEYWORDS="amd64 ~ia64 x86"
-LICENSE="GPL-2"
-
-PYTHON_MODNAME=biggles
-
-pkg_setup() {
- if ! built_with_use media-libs/plotutils X ; then
- eerror "${P} needs media-libs/plotutils built with"
- eerror "USE=\"X\", please rebuild it with X enabled"
- eerror "and emerge ${P} again."
- die "media-libs/plotutils built without USE=\"X\""
- fi
-}
-
-src_unpack() {
- distutils_src_unpack
-
- epatch "${FILESDIR}/${P}-numpy.patch"
-}
-
-src_install() {
- distutils_src_install
-
- dodir /usr/share/doc/${PF}/examples
- cp -r examples/* "${D}/usr/share/doc/${PF}/examples"
-}
-
-pkg_postinst() {
- ewarn "This version uses numpy instead of the numeric module."
- ewarn "If this causes any unforeseen problems please file a bug on"
- ewarn "http://bugs.gentoo.org."
-}
diff --git a/dev-python/python-biggles/python-biggles-1.6.5.ebuild b/dev-python/python-biggles/python-biggles-1.6.5.ebuild
deleted file mode 100644
index 77dd90c4f5b1..000000000000
--- a/dev-python/python-biggles/python-biggles-1.6.5.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/python-biggles-1.6.5.ebuild,v 1.1 2009/07/14 21:14:07 fauli Exp $
-
-EAPI=2
-
-inherit distutils
-
-MY_P=${P/python/python2}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A Python module for creating publication-quality 2D scientific plots."
-SRC_URI="mirror://sourceforge/biggles/${MY_P}.tar.gz"
-HOMEPAGE="http://biggles.sourceforge.net/"
-
-DEPEND="media-libs/plotutils[X]
- dev-python/numpy
- x11-libs/libSM
- x11-libs/libXext"
-RDEPEND="${DEPEND}"
-
-IUSE=""
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86"
-LICENSE="GPL-2"
-
-PYTHON_MODNAME=biggles
-
-src_install() {
- distutils_src_install
-
- dodir /usr/share/doc/${PF}/examples
- cp -r examples/* "${D}/usr/share/doc/${PF}/examples"
-}