summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-31 13:58:56 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-31 13:58:56 +0000
commita5d251e4ff741740c4725a45c380f92560a7c104 (patch)
tree0e6594f20a36b17bfb862f9affb62f36e8f72cee /dev-python/python-docs/python-docs-2.5.4.ebuild
parentversion bump (diff)
downloadgentoo-2-a5d251e4ff741740c4725a45c380f92560a7c104.tar.gz
gentoo-2-a5d251e4ff741740c4725a45c380f92560a7c104.tar.bz2
gentoo-2-a5d251e4ff741740c4725a45c380f92560a7c104.zip
Adding 2.5.4. Fixes half of #252317
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-docs/python-docs-2.5.4.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-2.5.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-2.5.4.ebuild b/dev-python/python-docs/python-docs-2.5.4.ebuild
new file mode 100644
index 000000000000..0d9c6de1070f
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.5.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.5.4.ebuild,v 1.1 2009/03/31 13:58:56 patrick Exp $
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/${PV}/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/html-${PV}.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="2.5"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack html-${PV}.tar.bz2
+ rm -f README python.dir
+}
+
+src_install() {
+ docinto html
+ cp -R "${S}"/Python-Docs-${PV}/* ${D}/usr/share/doc/${PF}/html
+}
+
+pkg_preinst() {
+ dodir /etc/env.d
+ echo "PYTHONDOCS=/usr/share/doc/${PF}/html/lib" > ${D}/etc/env.d/50python-docs
+}