summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-11-28 13:03:45 +0000
committerIan Delaney <idella4@gentoo.org>2013-11-28 13:03:45 +0000
commitdae23d736d0bec0dbbdf14369e88ef8fddce7e5a (patch)
tree0cb4c4004efe82598e1f94da58d3d09d61fb442b /dev-python/python-glanceclient
parentVersion bump. (diff)
downloadgentoo-2-dae23d736d0bec0dbbdf14369e88ef8fddce7e5a.tar.gz
gentoo-2-dae23d736d0bec0dbbdf14369e88ef8fddce7e5a.tar.bz2
gentoo-2-dae23d736d0bec0dbbdf14369e88ef8fddce7e5a.zip
switch herd, add IUSE doc, doc dep, update / uncomment test deps, add doc build & install, update test phase, testing support by (good ol') Chicago
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/ChangeLog9
-rw-r--r--dev-python/python-glanceclient/metadata.xml2
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-0.10.0-r1.ebuild67
3 files changed, 76 insertions, 2 deletions
diff --git a/dev-python/python-glanceclient/ChangeLog b/dev-python/python-glanceclient/ChangeLog
index 68e5cdb2937e..ddb749a3a684 100644
--- a/dev-python/python-glanceclient/ChangeLog
+++ b/dev-python/python-glanceclient/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-glanceclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/ChangeLog,v 1.6 2013/08/11 01:43:36 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/ChangeLog,v 1.7 2013/11/28 13:03:45 idella4 Exp $
+
+*python-glanceclient-0.10.0-r1 (28 Nov 2013)
+
+ 28 Nov 2013; Ian Delaney <idella4@gentoo.org>
+ +python-glanceclient-0.10.0-r1.ebuild, metadata.xml:
+ switch herd, add IUSE doc, doc dep, update / uncomment test deps, add doc
+ build & install, update test phase, testing support by (good ol') Chicago
*python-glanceclient-0.10.0 (11 Aug 2013)
diff --git a/dev-python/python-glanceclient/metadata.xml b/dev-python/python-glanceclient/metadata.xml
index 2d9cce40a14e..7ecd625c6daa 100644
--- a/dev-python/python-glanceclient/metadata.xml
+++ b/dev-python/python-glanceclient/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
+ <herd>openstack</herd>
<maintainer>
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
diff --git a/dev-python/python-glanceclient/python-glanceclient-0.10.0-r1.ebuild b/dev-python/python-glanceclient/python-glanceclient-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..0aa811be6a9d
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-0.10.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/python-glanceclient-0.10.0-r1.ebuild,v 1.1 2013/11/28 13:03:45 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mox[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ >=dev-python/pep8-1.3.3[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-git-0.4[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.13[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]
+ =dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.5.3[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.6[${PYTHON_USEDEP}]
+ dev-python/mox[${PYTHON_USEDEP}]
+ >=dev-python/mock-0.8.0[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx )
+ "
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
+ >=dev-python/d2to1-0.2.10[${PYTHON_USEDEP}]
+ <dev-python/d2to1-0.3[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5[${PYTHON_USEDEP}]
+ <dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.2.1[${PYTHON_USEDEP}]
+ <dev-python/python-keystoneclient-1[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/warlock-0.7.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -e 's:intersphinx_mapping:_&:' -i doc/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ testr init
+ testr run || die "testsuite failed under python2.7"
+ flake8 tests && einfo "run flake8 over tests folder passed" || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}