summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-03-18 02:02:11 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-03-18 02:02:11 +0000
commit197f1a5d182d9046ac62902d65d199625c4496a5 (patch)
tree01e016e2812192507c4d247d3764f9f1f719a8dc /dev-python/python-selinux
parentVersion bump (diff)
downloadgentoo-2-197f1a5d182d9046ac62902d65d199625c4496a5.tar.gz
gentoo-2-197f1a5d182d9046ac62902d65d199625c4496a5.tar.bz2
gentoo-2-197f1a5d182d9046ac62902d65d199625c4496a5.zip
Fix bug #355675
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-selinux')
-rw-r--r--dev-python/python-selinux/ChangeLog8
-rw-r--r--dev-python/python-selinux/files/respect-LDFLAGS.patch11
-rw-r--r--dev-python/python-selinux/python-selinux-2.16-r3.ebuild41
3 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/python-selinux/ChangeLog b/dev-python/python-selinux/ChangeLog
index b3979c8640b3..4c7511a9c1a6 100644
--- a/dev-python/python-selinux/ChangeLog
+++ b/dev-python/python-selinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-selinux
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.40 2011/02/13 19:45:03 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.41 2011/03/18 02:02:11 blueness Exp $
+
+*python-selinux-2.16-r3 (18 Mar 2011)
+
+ 18 Mar 2011; Anthony G. Basile <blueness@gentoo.org>
+ +python-selinux-2.16-r3.ebuild, +files/respect-LDFLAGS.patch:
+ Fix bug #355675
13 Feb 2011; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
Updated metadata.xml to reflect new selinux herd.
diff --git a/dev-python/python-selinux/files/respect-LDFLAGS.patch b/dev-python/python-selinux/files/respect-LDFLAGS.patch
new file mode 100644
index 000000000000..d52bbafde3a6
--- /dev/null
+++ b/dev-python/python-selinux/files/respect-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- python-selinux-orig/Makefile 2006-02-12 04:37:05.000000000 +0300
++++ python-selinux/Makefile 2011-02-22 19:06:02.000000000 +0300
+@@ -23,7 +23,7 @@
+ $(PYREXC) $<
+
+ %.so: %.c
+- $(CC) -fPIC -shared -o $@ -I /usr/include/python${PYVER} $< -lselinux
++ $(CC) -fPIC -shared -o $@ -I /usr/include/python${PYVER} ${CFLAGS} ${LDFLAGS} $< -lselinux
+
+ install: $(all_so)
+ mkdir -p ${DESTDIR}/usr/lib/python${PYVER}/site-packages
diff --git a/dev-python/python-selinux/python-selinux-2.16-r3.ebuild b/dev-python/python-selinux/python-selinux-2.16-r3.ebuild
new file mode 100644
index 000000000000..fae33eb2717a
--- /dev/null
+++ b/dev-python/python-selinux/python-selinux-2.16-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.16-r3.ebuild,v 1.1 2011/03/18 02:02:11 blueness Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+
+inherit python eutils
+
+DESCRIPTION="Extra python bindings for SELinux functions"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
+LICENSE="GPL-2"
+SLOT="0"
+SRC_URI="mirror://gentoo/${P}-1.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/libselinux-1.28-r1"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/respect-LDFLAGS.patch"
+}
+
+src_compile() {
+ emake PYVER="$(python_get_version)" || die
+}
+
+src_install() {
+ python_need_rebuild
+ make DESTDIR="${D}" PYVER="$(python_get_version)" install || die
+}