summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-03-30 05:06:16 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-03-30 05:06:16 +0000
commit929a52d9f186d938e4555b0c3e2ae8ded9f57347 (patch)
treeba21ae66f353e7f68257fde100bc3eadb0360cda /dev-python/python-swiftclient
parentnew bump (diff)
downloadgentoo-2-929a52d9f186d938e4555b0c3e2ae8ded9f57347.tar.gz
gentoo-2-929a52d9f186d938e4555b0c3e2ae8ded9f57347.tar.bz2
gentoo-2-929a52d9f186d938e4555b0c3e2ae8ded9f57347.zip
bup
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-swiftclient')
-rw-r--r--dev-python/python-swiftclient/ChangeLog8
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-1.9.0.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-python/python-swiftclient/ChangeLog b/dev-python/python-swiftclient/ChangeLog
index d661209d7487..78875842f09a 100644
--- a/dev-python/python-swiftclient/ChangeLog
+++ b/dev-python/python-swiftclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-swiftclient
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/ChangeLog,v 1.11 2014/03/19 23:11:13 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/ChangeLog,v 1.12 2014/03/30 05:06:16 prometheanfire Exp $
+
+*python-swiftclient-1.9.0 (30 Mar 2014)
+
+ 30 Mar 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +python-swiftclient-1.9.0.ebuild:
+ bup
19 Mar 2014; Sébastien Fabbro <bicatali@gentoo.org>
python-swiftclient-2.0.2.ebuild:
diff --git a/dev-python/python-swiftclient/python-swiftclient-1.9.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-1.9.0.ebuild
new file mode 100644
index 000000000000..8b5891eb928e
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-1.9.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/python-swiftclient-1.9.0.ebuild,v 1.1 2014/03/30 05:06:16 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="https://launchpad.net/python-swiftclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5[${PYTHON_USEDEP}]
+ test? ( ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.4.2[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}] )
+ )"
+RDEPEND=">=dev-python/simplejson-2.0.9[${PYTHON_USEDEP}]
+ >=dev-python/d2to1-0.2.10[${PYTHON_USEDEP}]
+ <dev-python/d2to1-0.3[${PYTHON_USEDEP}]"
+
+python_prepare() {
+ sed -i '/discover/d' "${S}/test-requirements.txt" || die "sed failed"
+ distutils-r1_python_prepare
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ testr init
+ testr run || die "tests failed under python2_7"
+ flake8 tests && einfo "run of tests folder by flake8 passed"
+ flake8 bin/swift && einfo "run of ./bin/swift by flake8 passed"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( ../${P}-python2_7/doc/build/html/. )
+ distutils-r1_python_install_all
+}