summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-17 13:52:40 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-17 13:52:40 +0000
commitaa5ed1ec34dd80248de1cfaf8da47453831b1754 (patch)
tree1284765f251335235e2b5c6b12d2730fae5d26dd /dev-python/python-twitter
parentStable for alpha, wrt bug #507866 (diff)
downloadgentoo-2-aa5ed1ec34dd80248de1cfaf8da47453831b1754.tar.gz
gentoo-2-aa5ed1ec34dd80248de1cfaf8da47453831b1754.tar.bz2
gentoo-2-aa5ed1ec34dd80248de1cfaf8da47453831b1754.zip
bump; drop py2.6 support, upgrade deps, ebuild generally, drop IUSE doc due to absence of a doc folder in source
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-twitter')
-rw-r--r--dev-python/python-twitter/ChangeLog11
-rw-r--r--dev-python/python-twitter/python-twitter-0.8.5.ebuild48
-rw-r--r--dev-python/python-twitter/python-twitter-1.1.ebuild36
3 files changed, 45 insertions, 50 deletions
diff --git a/dev-python/python-twitter/ChangeLog b/dev-python/python-twitter/ChangeLog
index ffe64443f331..60ef9a75b2a2 100644
--- a/dev-python/python-twitter/ChangeLog
+++ b/dev-python/python-twitter/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-twitter
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-twitter/ChangeLog,v 1.14 2013/09/05 18:47:04 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-twitter/ChangeLog,v 1.15 2014/05/17 13:52:40 idella4 Exp $
+
+*python-twitter-1.1 (17 May 2014)
+
+ 17 May 2014; Ian Delaney <idella4@gentoo.org> +python-twitter-1.1.ebuild,
+ -python-twitter-0.8.5.ebuild:
+ bump; drop py2.6 support, upgrade deps, ebuild generally, drop IUSE doc due to
+ absence of a doc folder in source
05 Sep 2013; Michał Górny <mgorny@gentoo.org> python-twitter-1.0.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/dev-python/python-twitter/python-twitter-0.8.5.ebuild b/dev-python/python-twitter/python-twitter-0.8.5.ebuild
deleted file mode 100644
index 4cbee9d20e93..000000000000
--- a/dev-python/python-twitter/python-twitter-0.8.5.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-twitter/python-twitter-0.8.5.ebuild,v 1.2 2013/06/17 09:05:20 djc Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="This library provides a pure python interface for the Twitter API"
-HOMEPAGE="http://code.google.com/p/python-twitter/"
-SRC_URI="http://python-twitter.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="examples"
-
-RDEPEND="dev-python/oauth2
- dev-python/simplejson"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-RESTRICT_PYTHON_ABIS="3.*"
-
-DOCS="CHANGES README.md"
-PYTHON_MODNAME="twitter.py"
-
-src_prepare() {
- distutils_src_prepare
-
- # Delete internal copy of simplejson.
- rm -fr simplejson
-}
-
-python_test() {
- esetup.py test
-}
-
-src_install() {
- distutils_src_install
-
- dohtml doc/twitter.html
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*
- fi
-}
diff --git a/dev-python/python-twitter/python-twitter-1.1.ebuild b/dev-python/python-twitter/python-twitter-1.1.ebuild
new file mode 100644
index 000000000000..98f8664df2ee
--- /dev/null
+++ b/dev-python/python-twitter/python-twitter-1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-twitter/python-twitter-1.1.ebuild,v 1.1 2014/05/17 13:52:40 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="This library provides a pure python interface for the Twitter API"
+HOMEPAGE="http://code.google.com/p/python-twitter/"
+SRC_URI="http://python-twitter.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="examples"
+
+RDEPEND="dev-python/oauth2[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# Testsuite in the source is not convincing in its completeness
+RESTRICT="test"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # Delete internal copy of simplejson.
+ rm -fr simplejson || die
+}
+
+# http://code.google.com/p/python-twitter/issues/detail?id=259&thanks=259&ts=1400334214
+python_test() {
+ esetup.py test
+}