summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-12-19 04:35:42 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-12-19 04:35:42 +0000
commit4c981491b3f9e9b5c6258ffe5e1b495b5bfa7c26 (patch)
tree26006a504147f7a3eaeaf261c236fe02a5a3525b /dev-python/requests-cache
parentversion bump, bug 532828 (diff)
downloadgentoo-2-4c981491b3f9e9b5c6258ffe5e1b495b5bfa7c26.tar.gz
gentoo-2-4c981491b3f9e9b5c6258ffe5e1b495b5bfa7c26.tar.bz2
gentoo-2-4c981491b3f9e9b5c6258ffe5e1b495b5bfa7c26.zip
Bump
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/ChangeLog7
-rw-r--r--dev-python/requests-cache/requests-cache-0.4.8.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/requests-cache/ChangeLog b/dev-python/requests-cache/ChangeLog
index d81451cf8c19..a1767a48af8c 100644
--- a/dev-python/requests-cache/ChangeLog
+++ b/dev-python/requests-cache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/requests-cache
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests-cache/ChangeLog,v 1.11 2014/10/17 02:47:33 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests-cache/ChangeLog,v 1.12 2014/12/19 04:35:42 patrick Exp $
+
+*requests-cache-0.4.8 (19 Dec 2014)
+
+ 19 Dec 2014; Patrick Lauer <patrick@gentoo.org> +requests-cache-0.4.8.ebuild:
+ Bump
17 Oct 2014; Mike Gilbert <floppym@gentoo.org> requests-cache-0.4.5.ebuild,
requests-cache-0.4.6.ebuild:
diff --git a/dev-python/requests-cache/requests-cache-0.4.8.ebuild b/dev-python/requests-cache/requests-cache-0.4.8.ebuild
new file mode 100644
index 000000000000..5a8f4a7b6808
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-0.4.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests-cache/requests-cache-0.4.8.ebuild,v 1.1 2014/12/19 04:35:42 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+HOMEPAGE="https://pypi.python.org/pypi/requests-cache"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+# Portage only has versions of request >= minimum border
+RDEPEND=">=dev-python/requests-1.0.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Testsuite excels in tests connecting to the network via local server daemons
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}