summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2014-09-27 18:51:41 +0000
committerAlex Brandt <alunduil@gentoo.org>2014-09-27 18:51:41 +0000
commit98297517ae26c87b065a6e292db09498fa7056b4 (patch)
treecd8995b14453af614e694ce05a8b8cd938bf9be1 /dev-python/requests-mock
parentSpelling. (diff)
downloadgentoo-2-98297517ae26c87b065a6e292db09498fa7056b4.tar.gz
gentoo-2-98297517ae26c87b065a6e292db09498fa7056b4.tar.bz2
gentoo-2-98297517ae26c87b065a6e292db09498fa7056b4.zip
add new ebuild for requests-mock
Required as a dependency for the testing of packages involved with dev-python/python-keystoneclient. (Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 92FEA28B)
Diffstat (limited to 'dev-python/requests-mock')
-rw-r--r--dev-python/requests-mock/ChangeLog10
-rw-r--r--dev-python/requests-mock/metadata.xml7
-rw-r--r--dev-python/requests-mock/requests-mock-0.5.1.ebuild41
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/requests-mock/ChangeLog b/dev-python/requests-mock/ChangeLog
new file mode 100644
index 000000000000..a79584050983
--- /dev/null
+++ b/dev-python/requests-mock/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/requests-mock
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests-mock/ChangeLog,v 1.1 2014/09/27 18:51:41 alunduil Exp $
+
+*requests-mock-0.5.1 (27 Sep 2014)
+
+ 27 Sep 2014; Alex Brandt <alunduil@gentoo.org> +requests-mock-0.5.1.ebuild,
+ +metadata.xml:
+ new ebuild written by me—dependency for python-keystoneclient
+
diff --git a/dev-python/requests-mock/metadata.xml b/dev-python/requests-mock/metadata.xml
new file mode 100644
index 000000000000..1c0f48ee31dd
--- /dev/null
+++ b/dev-python/requests-mock/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/requests-mock/requests-mock-0.5.1.ebuild b/dev-python/requests-mock/requests-mock-0.5.1.ebuild
new file mode 100644
index 000000000000..3ddf926ca4fc
--- /dev/null
+++ b/dev-python/requests-mock/requests-mock-0.5.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests-mock/requests-mock-0.5.1.ebuild,v 1.1 2014/09/27 18:51:41 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock out responses from the requests package"
+HOMEPAGE="https://github.com/jamielennox/requests-mock"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# NOTE: docs do not install due to pbr configuration issues
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}