summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-06-01 08:37:30 +0000
committerTim Harder <radhermit@gentoo.org>2013-06-01 08:37:30 +0000
commit9daebd3a472bdd62ea4cc23523c176832b3ee6b0 (patch)
treecd9ca2600bde1e159432eecf27488212f1b5d08c /dev-python/requests
parentVersion bump. (diff)
downloadgentoo-2-9daebd3a472bdd62ea4cc23523c176832b3ee6b0.tar.gz
gentoo-2-9daebd3a472bdd62ea4cc23523c176832b3ee6b0.tar.bz2
gentoo-2-9daebd3a472bdd62ea4cc23523c176832b3ee6b0.zip
Version bump.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/requests')
-rw-r--r--dev-python/requests/ChangeLog7
-rw-r--r--dev-python/requests/requests-1.2.3.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/requests/ChangeLog b/dev-python/requests/ChangeLog
index dc8707f7fe1e..dcb9340281dc 100644
--- a/dev-python/requests/ChangeLog
+++ b/dev-python/requests/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/requests
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.40 2013/05/22 07:14:25 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.41 2013/06/01 08:37:30 radhermit Exp $
+
+*requests-1.2.3 (01 Jun 2013)
+
+ 01 Jun 2013; Tim Harder <radhermit@gentoo.org> +requests-1.2.3.ebuild:
+ Version bump.
*requests-1.2.2 (22 May 2013)
diff --git a/dev-python/requests/requests-1.2.3.ebuild b/dev-python/requests/requests-1.2.3.ebuild
new file mode 100644
index 000000000000..11b434d4daf3
--- /dev/null
+++ b/dev-python/requests/requests-1.2.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-1.2.3.ebuild,v 1.1 2013/06/01 08:37:30 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library for human beings"
+HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+# bundles dev-python/urllib3 snapshot
+RDEPEND="app-misc/ca-certificates
+ dev-python/charade[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# tests connect to various remote sites
+RESTRICT="test"
+
+DOCS=( README.rst HISTORY.rst )
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.0-system-cacerts.patch
+ "${FILESDIR}"/${PN}-1.2.0-system-libs.patch
+ "${FILESDIR}"/${PN}-1.2.1-urllib3-py3.patch
+ )
+
+ # use system charade
+ rm -r requests/packages/charade || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}