summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-05 18:16:31 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-05 18:16:31 +0000
commite2633d20a253171c6f422fb3d363020045e4fb8c (patch)
tree1f56fb2a32a1ead668c222e782cc068315a84638 /dev-python/requests
parentStable on amd64. Bug #548530. (diff)
downloadgentoo-2-e2633d20a253171c6f422fb3d363020045e4fb8c.tar.gz
gentoo-2-e2633d20a253171c6f422fb3d363020045e4fb8c.tar.bz2
gentoo-2-e2633d20a253171c6f422fb3d363020045e4fb8c.zip
Version Bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/requests')
-rw-r--r--dev-python/requests/ChangeLog7
-rw-r--r--dev-python/requests/requests-2.7.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/requests/ChangeLog b/dev-python/requests/ChangeLog
index 5921ae4fca4a..cf58dbcb3548 100644
--- a/dev-python/requests/ChangeLog
+++ b/dev-python/requests/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/requests
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.94 2015/05/05 18:08:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.95 2015/05/05 18:16:31 jlec Exp $
+
+*requests-2.7.0 (05 May 2015)
+
+ 05 May 2015; Justin Lecher <jlec@gentoo.org> +requests-2.7.0.ebuild:
+ Version Bump
*requests-2.6.1 (05 May 2015)
diff --git a/dev-python/requests/requests-2.7.0.ebuild b/dev-python/requests/requests-2.7.0.ebuild
new file mode 100644
index 000000000000..fe615a8af9ea
--- /dev/null
+++ b/dev-python/requests/requests-2.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-2.7.0.ebuild,v 1.1 2015/05/05 18:16:31 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library for human beings"
+HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+# bundles dev-python/urllib3 snapshot
+RDEPEND="
+ app-misc/ca-certificates
+ >=dev-python/chardet-2.2.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# tests connect to various remote sites
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.0-system-chardet.patch
+ "${FILESDIR}"/${PN}-2.5.0-system-cacerts.patch
+)
+
+python_prepare_all() {
+ # use system chardet
+ rm -r requests/packages/chardet || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" test_requests.py || die "Tests fail with ${EPYTHON}"
+}