summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-02 23:33:12 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-02 23:33:12 +0000
commit663eda1c3d5bc0291d581622d47f1ea545b22035 (patch)
treee27cf2cf44f4565af88b34499615b50d03cd0f20 /dev-python/routes
parentRemove remaining qt3 useflag usage (diff)
downloadgentoo-2-663eda1c3d5bc0291d581622d47f1ea545b22035.tar.gz
gentoo-2-663eda1c3d5bc0291d581622d47f1ea545b22035.tar.bz2
gentoo-2-663eda1c3d5bc0291d581622d47f1ea545b22035.zip
Use documentation already present in the tarball instead of generating it
in src_compile() to fix building wiht USE="doc" (bug #297795). (Portage version: 15156-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/routes')
-rw-r--r--dev-python/routes/ChangeLog9
-rw-r--r--dev-python/routes/routes-1.11.ebuild18
2 files changed, 13 insertions, 14 deletions
diff --git a/dev-python/routes/ChangeLog b/dev-python/routes/ChangeLog
index 73e22d3f25e4..a525c4836abc 100644
--- a/dev-python/routes/ChangeLog
+++ b/dev-python/routes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/routes
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/ChangeLog,v 1.8 2009/12/20 10:31:25 grobian Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/ChangeLog,v 1.9 2010/01/02 23:33:12 arfrever Exp $
+
+ 02 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ routes-1.11.ebuild:
+ Use documentation already present in the tarball instead of generating it
+ in src_compile() to fix building wiht USE="doc" (bug #297795).
20 Dec 2009; Fabian Groffen <grobian@gentoo.org> routes-1.11.ebuild:
Merged keywords from Prefix overlay
diff --git a/dev-python/routes/routes-1.11.ebuild b/dev-python/routes/routes-1.11.ebuild
index 1a8b6a55273e..50eb6514ff39 100644
--- a/dev-python/routes/routes-1.11.ebuild
+++ b/dev-python/routes/routes-1.11.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/routes-1.11.ebuild,v 1.2 2009/12/20 10:31:25 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/routes-1.11.ebuild,v 1.3 2010/01/02 23:33:12 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -20,21 +20,12 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="doc test"
DEPEND="dev-python/setuptools
- doc? ( dev-python/buildutils dev-python/pudge )
test? ( dev-python/coverage dev-python/nose )"
RDEPEND=""
RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- PYTHONPATH=. "${python}" setup.py pudge || die "Generation of documentation failed"
- fi
-}
-
src_test() {
testing() {
PYTHONPATH="build-${PYTHON_ABI}" nosetests-${PYTHON_ABI}
@@ -44,5 +35,8 @@ src_test() {
src_install() {
distutils_src_install
- use doc && dohtml -r docs/html/*
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "dohtml failed"
+ fi
}