summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-07 04:41:34 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-07 04:41:34 +0000
commit326fc8ff84338cfa8aa3959cef61358beaf65ff2 (patch)
tree91aea8d03e97b7e3f0e3a22f348c94a23ff93caf /dev-python/rtgraph
parentrevbump; conversion -> distutils-r1, rm old (diff)
downloadgentoo-2-326fc8ff84338cfa8aa3959cef61358beaf65ff2.tar.gz
gentoo-2-326fc8ff84338cfa8aa3959cef61358beaf65ff2.tar.bz2
gentoo-2-326fc8ff84338cfa8aa3959cef61358beaf65ff2.zip
revbump; conversion -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/rtgraph')
-rw-r--r--dev-python/rtgraph/ChangeLog10
-rw-r--r--dev-python/rtgraph/rtgraph-0.70-r1.ebuild (renamed from dev-python/rtgraph/rtgraph-0.70.ebuild)31
2 files changed, 23 insertions, 18 deletions
diff --git a/dev-python/rtgraph/ChangeLog b/dev-python/rtgraph/ChangeLog
index a951e94700f9..968f8b60607c 100644
--- a/dev-python/rtgraph/ChangeLog
+++ b/dev-python/rtgraph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/rtgraph
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rtgraph/ChangeLog,v 1.11 2014/08/10 21:21:24 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rtgraph/ChangeLog,v 1.12 2015/01/07 04:41:34 idella4 Exp $
+
+*rtgraph-0.70-r1 (07 Jan 2015)
+
+ 07 Jan 2015; Ian Delaney <idella4@gentoo.org> +rtgraph-0.70-r1.ebuild,
+ -rtgraph-0.70.ebuild:
+ revbump; conversion -> distutils-r1, rm old
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> rtgraph-0.70.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/dev-python/rtgraph/rtgraph-0.70.ebuild b/dev-python/rtgraph/rtgraph-0.70-r1.ebuild
index ce9f0aa66676..5ac6ec5eb1f6 100644
--- a/dev-python/rtgraph/rtgraph-0.70.ebuild
+++ b/dev-python/rtgraph/rtgraph-0.70-r1.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rtgraph/rtgraph-0.70.ebuild,v 1.9 2014/08/10 21:21:24 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rtgraph/rtgraph-0.70-r1.ebuild,v 1.1 2015/01/07 04:41:34 idella4 Exp $
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
-inherit distutils
+inherit distutils-r1
DESCRIPTION="Widgets for graphing data in real-time using PyGTK, and UI components for controlling the graphs"
HOMEPAGE="http://navi.cx/svn/misc/trunk/rtgraph/web/index.html"
@@ -18,17 +16,18 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
IUSE="examples"
-DEPEND="dev-python/pygtk:2"
+DEPEND="dev-python/pygtk:2[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
-DOCS="BUGS README"
-PYTHON_MODNAME="rtgraph.py Tweak.py"
-
-src_install() {
- distutils_src_install
-
+python_prepare_all() {
if use examples; then
- insinto /usr/share/doc/${P}/examples
- doins cpu_meter.py graph_ui.py isometric_graph.py line_graph.py polar_graph.py tweak_graph.py || die "Installation of examples failed"
+ mkdir examples || die
+ mv ./{cpu_meter.py,graph_ui.py,isometric_graph.py,line_graph.py,polar_graph.py,tweak_graph.py} examples || die
fi
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
}