summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-30 22:07:22 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-30 22:07:22 +0000
commit5cae59eaee702b12d0fc6385829f03218f9951e5 (patch)
tree85988b4c3ea18f0c567b7d9666dc2e644dbb5724 /dev-python/rtgraph
parentFix dependencies. Set SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-5cae59eaee702b12d0fc6385829f03218f9951e5.tar.gz
gentoo-2-5cae59eaee702b12d0fc6385829f03218f9951e5.tar.bz2
gentoo-2-5cae59eaee702b12d0fc6385829f03218f9951e5.zip
Fix dependencies. Set SUPPORT_PYTHON_ABIS. Add "examples" USE flag.
(Portage version: 2.2.0_alpha10_p22/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/rtgraph')
-rw-r--r--dev-python/rtgraph/ChangeLog8
-rw-r--r--dev-python/rtgraph/rtgraph-0.70.ebuild30
2 files changed, 26 insertions, 12 deletions
diff --git a/dev-python/rtgraph/ChangeLog b/dev-python/rtgraph/ChangeLog
index 03985bb34afc..8ef1f93d4303 100644
--- a/dev-python/rtgraph/ChangeLog
+++ b/dev-python/rtgraph/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/rtgraph
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rtgraph/ChangeLog,v 1.8 2007/02/21 17:19:47 lucass Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rtgraph/ChangeLog,v 1.9 2010/12/30 22:07:22 arfrever Exp $
+
+ 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ rtgraph-0.70.ebuild:
+ Fix dependencies. Set SUPPORT_PYTHON_ABIS. Add "examples" USE flag.
21 Feb 2007; Lukasz Strzygowski <lucass@gentoo.org>
files/digest-rtgraph-0.70, Manifest:
diff --git a/dev-python/rtgraph/rtgraph-0.70.ebuild b/dev-python/rtgraph/rtgraph-0.70.ebuild
index 8de8f3ff9ef3..56edee66224d 100644
--- a/dev-python/rtgraph/rtgraph-0.70.ebuild
+++ b/dev-python/rtgraph/rtgraph-0.70.ebuild
@@ -1,24 +1,34 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rtgraph/rtgraph-0.70.ebuild,v 1.6 2006/04/01 19:04:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rtgraph/rtgraph-0.70.ebuild,v 1.7 2010/12/30 22:07:22 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils
DESCRIPTION="rtgraph provides several widgets for graphing data in real-time, using PyGTK, and UI components for controlling the graphs."
HOMEPAGE="http://navi.cx/svn/misc/trunk/rtgraph/web/index.html"
SRC_URI="http://navi.picogui.org/releases/${P}.tar.gz"
+
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE=""
KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-DEPEND="virtual/python
- >=dev-python/pygtk-2"
+IUSE="examples"
+
+DEPEND="dev-python/pygtk:2"
+RDEPEND="${DEPEND}"
+
+DOCS="BUGS README"
+PYTHON_MODNAME="rtgraph.py Tweak.py"
src_install() {
distutils_src_install
- dodoc README BUGS
- dodir /usr/share/doc/${P}/examples
- insinto /usr/share/doc/${P}/examples
- doins cpu_meter.py graph_ui.py isometric_graph.py line_graph.py \
- polar_graph.py tweak_graph.py
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/examples
+ doins cpu_meter.py graph_ui.py isometric_graph.py line_graph.py polar_graph.py tweak_graph.py || die "Installation of examples failed"
+ fi
}