summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-04 17:04:51 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-04 17:04:51 +0000
commit86b6876559ffe356f76c698a48116cac4b49ef38 (patch)
tree718f8bf9bc2848a85d16cc9d75109a9e4b4c0b81 /dev-python/scientificpython/scientificpython-2.9.ebuild
parentRemove old (diff)
downloadgentoo-2-86b6876559ffe356f76c698a48116cac4b49ef38.tar.gz
gentoo-2-86b6876559ffe356f76c698a48116cac4b49ef38.tar.bz2
gentoo-2-86b6876559ffe356f76c698a48116cac4b49ef38.zip
Bump to 2.9, remove old
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/scientificpython/scientificpython-2.9.ebuild')
-rw-r--r--dev-python/scientificpython/scientificpython-2.9.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/scientificpython/scientificpython-2.9.ebuild b/dev-python/scientificpython/scientificpython-2.9.ebuild
new file mode 100644
index 000000000000..6199554ed64f
--- /dev/null
+++ b/dev-python/scientificpython/scientificpython-2.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/scientificpython-2.9.ebuild,v 1.1 2009/09/04 17:04:51 patrick Exp $
+
+MY_PN=ScientificPython
+DV=2372 # hardcoded download version
+
+inherit eutils distutils
+
+DESCRIPTION="Scientific Module for Python"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${DV}/${MY_PN}-${PV}.tar.gz"
+HOMEPAGE="http://sourcesup.cru.fr/projects/scientific-py/"
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="mpi doc"
+
+DEPEND="dev-python/numpy
+ sci-libs/netcdf
+ mpi? ( virtual/mpi )"
+
+S="${WORKDIR}/${MY_PN}-${PV}.0"
+
+src_compile() {
+ distutils_src_compile
+ if use mpi; then
+ cd Src/MPI
+ PYTHONPATH=$(ls -d "${S}"/build/lib*) \
+ "${python}" compile.py || die "compile mpi failed"
+ fi
+}
+
+src_test() {
+ cd "${S}"/build/lib*
+ for t in "${S}"/Tests/*tests.py; do
+ PYTHONPATH=. "${python}" ${t} || die "test $(basename ${t}) failed"
+ done
+}
+
+src_install() {
+ distutils_src_install
+ # do not install bsp related stuff, since we don't compile the interface
+ dodoc README README.MPI Doc/CHANGELOG || die "dodoc failed"
+ insinto /usr/share/doc/${PF}
+ doins Examples/{demomodule.c,netcdf_demo.py} || die "doins examples failed"
+ if use mpi; then
+ dobin Src/MPI/mpipython || die "dobin failed"
+ doins Examples/mpi.py || die "doins mpi example failed failed"
+ fi
+ if use doc; then
+ dohtml Doc/Reference/* || die "dohtml failed"
+ fi
+}