summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-03-03 20:59:40 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-03-03 20:59:40 +0000
commit3d0bc8e288f627a00df517b28fbb43bc29e8d789 (patch)
tree78af80d495bd28f9eac7523ca635b26a630a87be /dev-python/spyder
parentCleaner configure.ac (fixes on sh warning). (diff)
downloadgentoo-2-3d0bc8e288f627a00df517b28fbb43bc29e8d789.tar.gz
gentoo-2-3d0bc8e288f627a00df517b28fbb43bc29e8d789.tar.bz2
gentoo-2-3d0bc8e288f627a00df517b28fbb43bc29e8d789.zip
Version bump
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/ChangeLog10
-rw-r--r--dev-python/spyder/files/spyder-2.2.5-disable_sphinx_dependency.patch70
-rw-r--r--dev-python/spyder/spyder-2.2.5.ebuild51
3 files changed, 129 insertions, 2 deletions
diff --git a/dev-python/spyder/ChangeLog b/dev-python/spyder/ChangeLog
index 99b04f6c7101..4ecf9212d272 100644
--- a/dev-python/spyder/ChangeLog
+++ b/dev-python/spyder/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/spyder
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.32 2013/07/18 16:41:22 bicatali Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.33 2014/03/03 20:59:40 bicatali Exp $
+
+*spyder-2.2.5 (03 Mar 2014)
+
+ 03 Mar 2014; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/spyder-2.2.5-disable_sphinx_dependency.patch, +spyder-2.2.5.ebuild:
+ Version bump
*spyder-2.2.1 (18 Jul 2013)
diff --git a/dev-python/spyder/files/spyder-2.2.5-disable_sphinx_dependency.patch b/dev-python/spyder/files/spyder-2.2.5-disable_sphinx_dependency.patch
new file mode 100644
index 000000000000..d548c3f1a5f4
--- /dev/null
+++ b/dev-python/spyder/files/spyder-2.2.5-disable_sphinx_dependency.patch
@@ -0,0 +1,70 @@
+--- setup.py.orig 2014-03-03 12:55:59.209248082 -0800
++++ setup.py 2014-03-03 12:57:08.651709021 -0800
+@@ -81,51 +81,6 @@
+ else:
+ return
+
+-try:
+- from sphinx import setup_command
+-
+- class MyBuild(build):
+- def has_doc(self):
+- setup_dir = os.path.dirname(os.path.abspath(__file__))
+- return os.path.isdir(os.path.join(setup_dir, 'doc'))
+- sub_commands = build.sub_commands + [('build_doc', has_doc)]
+- CMDCLASS['build'] = MyBuild
+- class MyBuildDoc(setup_command.BuildDoc):
+- def run(self):
+- build = self.get_finalized_command('build')
+- sys.path.insert(0, os.path.abspath(build.build_lib))
+- dirname = self.distribution.get_command_obj('build').build_purelib
+- self.builder_target_dir = osp.join(dirname, 'spyderlib', 'doc')
+-
+- hhc_exe = get_html_help_exe()
+- self.builder = "html" if hhc_exe is None else "htmlhelp"
+-
+- try:
+- setup_command.BuildDoc.run(self)
+- except UnicodeDecodeError:
+- print("ERROR: unable to build documentation because Sphinx "\
+- "do not handle source path with non-ASCII characters. "\
+- "Please try to move the source package to another "\
+- "location (path with *only* ASCII characters).",
+- file=sys.stderr)
+- sys.path.pop(0)
+-
+- # Building chm doc, if HTML Help Workshop is installed
+- if hhc_exe is not None:
+- fname = osp.join(self.builder_target_dir, 'Spyderdoc.chm')
+- subprocess.call('"%s" %s' % (hhc_exe, fname), shell=True)
+- if osp.isfile(fname):
+- dest = osp.join(dirname, 'spyderlib')
+- try:
+- shutil.move(fname, dest)
+- except shutil.Error:
+- print("Unable to replace %s" % dest)
+- shutil.rmtree(self.builder_target_dir)
+-
+- CMDCLASS['build_doc'] = MyBuildDoc
+-except ImportError:
+- print('WARNING: unable to build documentation because Sphinx '\
+- 'is not installed', file=sys.stderr)
+
+
+ NAME = 'spyder'
+@@ -191,7 +146,7 @@
+ package_data={LIBNAME: get_package_data(LIBNAME, EXTLIST),
+ 'spyderplugins':
+ get_package_data('spyderplugins', EXTLIST)},
+- requires=["rope (>=0.9.2)", "sphinx (>=0.6.0)", "PyQt4 (>=4.4)"],
++ requires=["rope (>=0.9.2)", "PyQt4 (>=4.4)"],
+ scripts=[osp.join('scripts', fname) for fname in SCRIPTS],
+ data_files=get_data_files(),
+ options={"bdist_wininst":
+@@ -212,5 +167,4 @@
+ 'Programming Language :: Python :: 2.7',
+ 'Development Status :: 5 - Production/Stable',
+ 'Topic :: Scientific/Engineering',
+- 'Topic :: Software Development :: Widget Sets'],
+- cmdclass=CMDCLASS)
++ 'Topic :: Software Development :: Widget Sets'])
diff --git a/dev-python/spyder/spyder-2.2.5.ebuild b/dev-python/spyder/spyder-2.2.5.ebuild
new file mode 100644
index 000000000000..916de1c9aee2
--- /dev/null
+++ b/dev-python/spyder/spyder-2.2.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.2.5.ebuild,v 1.1 2014/03/03 20:59:40 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python IDE with matlab-like features"
+HOMEPAGE="http://code.google.com/p/spyderlib/"
+SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc ipython matplotlib numpy pep8 +pyflakes pylint +rope scipy sphinx"
+
+RDEPEND="
+ || ( dev-python/PyQt4[${PYTHON_USEDEP},svg,webkit]
+ dev-python/pyside[${PYTHON_USEDEP},svg,webkit] )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
+ numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ pep8? ( dev-python/pep8[${PYTHON_USEDEP}] )
+ pyflakes? ( >=dev-python/pyflakes-0.3[${PYTHON_USEDEP}] )
+ pylint? ( dev-python/pylint[${PYTHON_USEDEP}] )
+ rope? ( >=dev-python/rope-0.9.3[${PYTHON_USEDEP}] )
+ scipy? ( sci-libs/scipy[${PYTHON_USEDEP}] )
+ sphinx? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( dev-python/sphinx )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.5-disable_sphinx_dependency.patch )
+
+python_compile() {
+ if use doc; then
+ einfo "Generation of documentation"
+ PYTHONPATH="{BUILD_DIR}" \
+ sphinx-build doc doc_output || die "Generation of documentation failed"
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doicon spyderlib/images/spyder.svg
+ make_desktop_entry spyder Spyder spyder "Development;IDE"
+ use doc && dohtml -r doc_output/*
+}