summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2013-03-19 06:41:01 +0000
committerAndrey Grozin <grozin@gentoo.org>2013-03-19 06:41:01 +0000
commit8029cd9b21547385e295bc94c68acdd5bef9cb07 (patch)
treea37f2477915487b2f5831c719c7f234e40711edb /dev-python/spyder
parentBump (diff)
downloadgentoo-2-8029cd9b21547385e295bc94c68acdd5bef9cb07.tar.gz
gentoo-2-8029cd9b21547385e295bc94c68acdd5bef9cb07.tar.bz2
gentoo-2-8029cd9b21547385e295bc94c68acdd5bef9cb07.zip
Qt version detection fixed, closing #461658; thanks to Reinis Danne <rei4dan@gmail.com> for the patch.
(Portage version: 2.2.0_alpha166/cvs/Linux i686, signed Manifest commit with key 00C6DAB1!)
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/ChangeLog11
-rw-r--r--dev-python/spyder/files/spyder-2.1.13-qt_requirements.patch11
-rw-r--r--dev-python/spyder/files/spyder-2.1.2-disable_sphinx_dependency.patch57
-rw-r--r--dev-python/spyder/spyder-2.1.13-r1.ebuild (renamed from dev-python/spyder/spyder-2.1.13.ebuild)7
-rw-r--r--dev-python/spyder/spyder-2.1.9.ebuild61
5 files changed, 25 insertions, 122 deletions
diff --git a/dev-python/spyder/ChangeLog b/dev-python/spyder/ChangeLog
index 24418da237cd..8f64d4948059 100644
--- a/dev-python/spyder/ChangeLog
+++ b/dev-python/spyder/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/spyder
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.30 2013/03/01 13:49:19 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.31 2013/03/19 06:41:01 grozin Exp $
+
+*spyder-2.1.13-r1 (19 Mar 2013)
+
+ 19 Mar 2013; Andrey Grozin <grozin@gentoo.org>
+ -files/spyder-2.1.2-disable_sphinx_dependency.patch, -spyder-2.1.9.ebuild,
+ -spyder-2.1.13.ebuild, +spyder-2.1.13-r1.ebuild,
+ +files/spyder-2.1.13-qt_requirements.patch:
+ Qt version detection fixed, closing #461658; thanks to Reinis Danne
+ <rei4dan@gmail.com> for the patch.
01 Mar 2013; Kacper Kowalik <xarthisius@gentoo.org> spyder-2.1.13.ebuild:
Fix dependency on PyQt4[svg]
diff --git a/dev-python/spyder/files/spyder-2.1.13-qt_requirements.patch b/dev-python/spyder/files/spyder-2.1.13-qt_requirements.patch
new file mode 100644
index 000000000000..cd1d6b67f90c
--- /dev/null
+++ b/dev-python/spyder/files/spyder-2.1.13-qt_requirements.patch
@@ -0,0 +1,11 @@
+--- spyderlib/requirements.py 2013-03-13 18:55:51.363304516 +0200
++++ spyderlib/requirements.py 2013-03-13 18:58:07.200608283 +0200
+@@ -14,6 +14,8 @@
+ """Return True if actual_str version fit required_str requirement"""
+ actual = actual_str.split('.')
+ required = required_str.split('.')
++ actual = [int(i) for i in actual]
++ required = [int(i.strip('+')) for i in required]
+ return actual[0] < required[0] or \
+ (actual[0] == required[0] and actual[1] < required[1])
+
diff --git a/dev-python/spyder/files/spyder-2.1.2-disable_sphinx_dependency.patch b/dev-python/spyder/files/spyder-2.1.2-disable_sphinx_dependency.patch
deleted file mode 100644
index f4fbba600ee1..000000000000
--- a/dev-python/spyder/files/spyder-2.1.2-disable_sphinx_dependency.patch
+++ /dev/null
@@ -1,57 +0,0 @@
---- setup.py
-+++ setup.py
-@@ -13,7 +13,6 @@
-
- from distutils.core import setup
- from distutils.command.build import build
--from sphinx import setup_command
- import os
- import os.path as osp
- import sys
-@@ -40,30 +39,6 @@
- return splist
-
-
--# Sphinx build (documentation)
--class MyBuild(build):
-- def has_doc(self):
-- setup_dir = os.path.dirname(os.path.abspath(__file__))
-- return os.path.isdir(os.path.join(setup_dir, 'doc'))
-- sub_commands = build.sub_commands + [('build_doc', has_doc)]
--
--
--class MyBuildDoc(setup_command.BuildDoc):
-- def run(self):
-- build = self.get_finalized_command('build')
-- sys.path.insert(0, os.path.abspath(build.build_lib))
-- dirname = self.distribution.get_command_obj('build').build_purelib
-- self.builder_target_dir = osp.join(dirname, 'spyderlib', 'doc')
-- try:
-- setup_command.BuildDoc.run(self)
-- except UnicodeDecodeError:
-- print >>sys.stderr, "ERROR: unable to build documentation because Sphinx do not handle source path with non-ASCII characters. Please try to move the source package to another location (path with *only* ASCII characters)."
-- sys.path.pop(0)
--
--
--cmdclass = {'build': MyBuild, 'build_doc': MyBuildDoc}
--
--
- NAME = 'spyder'
- LIBNAME = 'spyderlib'
- from spyderlib import __version__, __project_url__
-@@ -88,7 +63,7 @@
- get_package_data(LIBNAME, ('.mo', '.svg', '.png', '.css')),
- 'spyderplugins':
- get_package_data('spyderplugins', ('.mo', '.svg', '.png'))},
-- requires=["rope (>=0.9.2)", "sphinx (>=0.6.0)", "PyQt4 (>=4.4)"],
-+ requires=["rope (>=0.9.2)", "PyQt4 (>=4.4)"],
- scripts=[osp.join('scripts', fname) for fname in
- (['spyder', 'spyder.bat'] if os.name == 'nt' else ['spyder'])],
- classifiers=['License :: OSI Approved :: MIT License',
-@@ -102,5 +77,4 @@
- 'Programming Language :: Python :: 2.7',
- 'Development Status :: 5 - Production/Stable',
- 'Topic :: Scientific/Engineering',
-- 'Topic :: Software Development :: Widget Sets'],
-- cmdclass=cmdclass)
-+ 'Topic :: Software Development :: Widget Sets'])
diff --git a/dev-python/spyder/spyder-2.1.13.ebuild b/dev-python/spyder/spyder-2.1.13-r1.ebuild
index 4c4f748019e6..352938bae7b1 100644
--- a/dev-python/spyder/spyder-2.1.13.ebuild
+++ b/dev-python/spyder/spyder-2.1.13-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.1.13.ebuild,v 1.2 2013/03/01 13:49:19 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.1.13-r1.ebuild,v 1.1 2013/03/19 06:41:01 grozin Exp $
-EAPI="3"
+EAPI=5
PYTHON_DEPEND="2:2.5"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
@@ -36,7 +36,8 @@ PYTHON_MODNAME="spyderlib spyderplugins"
src_prepare() {
distutils_src_prepare
- epatch "${FILESDIR}"/${PN}-2.1.13-disable_sphinx_dependency.patch
+ epatch "${FILESDIR}"/${P}-disable_sphinx_dependency.patch
+ epatch "${FILESDIR}"/${P}-qt_requirements.patch
}
src_compile() {
diff --git a/dev-python/spyder/spyder-2.1.9.ebuild b/dev-python/spyder/spyder-2.1.9.ebuild
deleted file mode 100644
index 26ca0bb1dc95..000000000000
--- a/dev-python/spyder/spyder-2.1.9.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.1.9.ebuild,v 1.1 2012/04/17 14:53:25 xarthisius Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
-
-inherit distutils eutils
-
-DESCRIPTION="Python IDE with matlab-like features"
-HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
-SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc ipython matplotlib numpy pep8 +pyflakes pylint +rope scipy sphinx"
-
-RDEPEND=">=dev-python/PyQt4-4.4[webkit]
- ipython? ( dev-python/ipython )
- matplotlib? ( dev-python/matplotlib )
- numpy? ( dev-python/numpy )
- pep8? ( dev-python/pep8 )
- pyflakes? ( >=dev-python/pyflakes-0.3 )
- pylint? ( dev-python/pylint )
- rope? ( >=dev-python/rope-0.9.3 )
- scipy? ( sci-libs/scipy )
- sphinx? ( dev-python/sphinx )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-PYTHON_MODNAME="spyderlib spyderplugins"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${PN}-2.1.2-disable_sphinx_dependency.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- PYTHONPATH="build-$(PYTHON -f --ABI)" \
- sphinx-build doc doc_output || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
- doicon spyderlib/images/spyder.svg || die
- make_desktop_entry spyder Spyder spyder "Development;IDE"
- if use doc; then
- pushd doc_output > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _images _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-}