summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-02 17:50:03 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-02 17:50:03 +0000
commita84949d5bb0a48291a1be4d31b2bf8d612b6e242 (patch)
tree13b033d6d0dca9fcbe4c06294cdda917fc9e1ca8 /dev-python/spyder
parentKeyword amd64-linux and x86-linux (diff)
downloadgentoo-2-a84949d5bb0a48291a1be4d31b2bf8d612b6e242.tar.gz
gentoo-2-a84949d5bb0a48291a1be4d31b2bf8d612b6e242.tar.bz2
gentoo-2-a84949d5bb0a48291a1be4d31b2bf8d612b6e242.zip
Version bump. Keyword amd64-linux and x86-linux. Updated patch
(Portage version: 2.2.01.20796-prefix/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/ChangeLog11
-rw-r--r--dev-python/spyder/files/spyder-2.1.11-disable_sphinx_dependency.patch (renamed from dev-python/spyder/files/spyder-2.0.10-disable_sphinx_dependency.patch)114
-rw-r--r--dev-python/spyder/spyder-2.0.12.ebuild59
-rw-r--r--dev-python/spyder/spyder-2.1.11.ebuild (renamed from dev-python/spyder/spyder-2.1.7.ebuild)12
4 files changed, 75 insertions, 121 deletions
diff --git a/dev-python/spyder/ChangeLog b/dev-python/spyder/ChangeLog
index 4481dc61abb6..ce7767e080bc 100644
--- a/dev-python/spyder/ChangeLog
+++ b/dev-python/spyder/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/spyder
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.27 2012/04/17 14:53:25 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.28 2012/08/02 17:50:03 bicatali Exp $
+
+*spyder-2.1.11 (02 Aug 2012)
+
+ 02 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/spyder-2.1.11-disable_sphinx_dependency.patch, +spyder-2.1.11.ebuild,
+ -files/spyder-2.0.10-disable_sphinx_dependency.patch, -spyder-2.0.12.ebuild,
+ -spyder-2.1.7.ebuild:
+ Version bump. Keyword amd64-linux and x86-linux. Updated patch
*spyder-2.1.9 (17 Apr 2012)
@@ -146,4 +154,3 @@
20 Oct 2009; Andrey Grozin <grozin@gentoo.org> +spyder-1.0.0.ebuild,
+metadata.xml:
Initial import
-
diff --git a/dev-python/spyder/files/spyder-2.0.10-disable_sphinx_dependency.patch b/dev-python/spyder/files/spyder-2.1.11-disable_sphinx_dependency.patch
index 4ad34c2c06e2..b086de1e4e48 100644
--- a/dev-python/spyder/files/spyder-2.0.10-disable_sphinx_dependency.patch
+++ b/dev-python/spyder/files/spyder-2.1.11-disable_sphinx_dependency.patch
@@ -1,55 +1,61 @@
---- setup.py
-+++ setup.py
+--- setup.py.orig 2012-08-02 10:46:39.683501361 -0700
++++ setup.py 2012-08-02 10:48:16.479009298 -0700
@@ -13,7 +13,6 @@
-
- from distutils.core import setup
- from distutils.command.build import build
--from sphinx import setup_command
- import os, os.path as osp, sys
-
-
-@@ -36,27 +35,6 @@
- splist.append(".".join(dirpath.split(os.sep)))
- return splist
-
--# Sphinx build (documentation)
--class MyBuild(build):
-- def has_doc(self):
-- setup_dir = os.path.dirname(os.path.abspath(__file__))
-- return os.path.isdir(os.path.join(setup_dir, 'doc'))
-- sub_commands = build.sub_commands + [('build_doc', has_doc)]
--
--class MyBuildDoc(setup_command.BuildDoc):
-- def run(self):
-- build = self.get_finalized_command('build')
-- sys.path.insert(0, os.path.abspath(build.build_lib))
-- dirname = self.distribution.get_command_obj('build').build_purelib
-- self.builder_target_dir = osp.join(dirname, 'spyderlib', 'doc')
-- try:
-- setup_command.BuildDoc.run(self)
-- except UnicodeDecodeError:
-- print >>sys.stderr, "ERROR: unable to build documentation because Sphinx do not handle source path with non-ASCII characters. Please try to move the source package to another location (path with *only* ASCII characters)."
-- sys.path.pop(0)
--
--cmdclass = {'build': MyBuild, 'build_doc': MyBuildDoc}
--
-
- NAME = 'spyder'
- LIBNAME = 'spyderlib'
-@@ -83,8 +61,7 @@
- get_package_data(LIBNAME, ('.mo', '.svg', '.png', '.css')),
- 'spyderplugins':
- get_package_data('spyderplugins', ('.mo', '.svg', '.png'))},
-- requires=["pyflakes (>0.3.0)", "rope (>0.9.0)", "sphinx (>0.6.0)",
-- "PyQt4 (>4.3)"],
-+ requires=["pyflakes (>0.3.0)", "rope (>0.9.0)", "PyQt4 (>4.3)"],
- scripts=['spyder', 'spyder.bat'] if os.name == 'nt' else ['spyder'],
- classifiers=['License :: OSI Approved :: MIT License',
- 'Operating System :: MacOS',
-@@ -97,5 +74,4 @@
- 'Programming Language :: Python :: 2.7',
- 'Development Status :: 5 - Production/Stable',
- 'Topic :: Scientific/Engineering',
-- 'Topic :: Software Development :: Widget Sets'],
-- cmdclass=cmdclass)
-+ 'Topic :: Software Development :: Widget Sets'])
+
+ from distutils.core import setup
+ from distutils.command.build import build
+-from sphinx import setup_command
+ import os
+ import os.path as osp
+ import sys
+@@ -40,34 +39,6 @@
+ return splist
+
+
+-# Sphinx build (documentation)
+-class MyBuild(build):
+- def has_doc(self):
+- setup_dir = os.path.dirname(os.path.abspath(__file__))
+- return os.path.isdir(os.path.join(setup_dir, 'doc'))
+- sub_commands = build.sub_commands + [('build_doc', has_doc)]
+-
+-
+-class MyBuildDoc(setup_command.BuildDoc):
+- def run(self):
+- build = self.get_finalized_command('build')
+- sys.path.insert(0, os.path.abspath(build.build_lib))
+- dirname = self.distribution.get_command_obj('build').build_purelib
+- self.builder_target_dir = osp.join(dirname, 'spyderlib', 'doc')
+- try:
+- setup_command.BuildDoc.run(self)
+- except UnicodeDecodeError:
+- print >>sys.stderr, "ERROR: unable to build documentation "\
+- "because Sphinx do not handle source path "\
+- "with non-ASCII characters. Please try to "\
+- "move the source package to another location "\
+- "(path with *only* ASCII characters)."
+- sys.path.pop(0)
+-
+-
+-cmdclass = {'build': MyBuild, 'build_doc': MyBuildDoc}
+-
+-
+ NAME = 'spyder'
+ LIBNAME = 'spyderlib'
+ from spyderlib import __version__, __project_url__
+@@ -110,7 +81,7 @@
+ 'spyderplugins':
+ get_package_data('spyderplugins',
+ ('.mo', '.svg', '.png'))},
+- requires=["rope (>=0.9.2)", "sphinx (>=0.6.0)", "PyQt4 (>=4.4)"],
++ requires=["rope (>=0.9.2)", "PyQt4 (>=4.4)"],
+ scripts=[osp.join('scripts', fname) for fname in
+ (['spyder', 'spyder.bat', "%s_win_post_install.py" % NAME,
+ 'spyder.ico', 'spyder_light.ico']
+@@ -132,5 +103,4 @@
+ 'Programming Language :: Python :: 2.7',
+ 'Development Status :: 5 - Production/Stable',
+ 'Topic :: Scientific/Engineering',
+- 'Topic :: Software Development :: Widget Sets'],
+- cmdclass=cmdclass)
++ 'Topic :: Software Development :: Widget Sets'])
diff --git a/dev-python/spyder/spyder-2.0.12.ebuild b/dev-python/spyder/spyder-2.0.12.ebuild
deleted file mode 100644
index d19493768c23..000000000000
--- a/dev-python/spyder/spyder-2.0.12.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.0.12.ebuild,v 1.3 2012/02/20 14:31:12 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
-
-inherit distutils eutils
-
-DESCRIPTION="Python IDE with matlab-like features"
-HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
-SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc ipython matplotlib numpy +pyflakes pylint +rope scipy"
-
-RDEPEND=">=dev-python/PyQt4-4.4[webkit]
- ipython? ( dev-python/ipython )
- matplotlib? ( dev-python/matplotlib )
- numpy? ( dev-python/numpy )
- pyflakes? ( >=dev-python/pyflakes-0.3 )
- pylint? ( dev-python/pylint )
- rope? ( >=dev-python/rope-0.9.0 )
- scipy? ( sci-libs/scipy )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-PYTHON_MODNAME="spyderlib spyderplugins"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${PN}-2.0.10-disable_sphinx_dependency.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- PYTHONPATH="build-$(PYTHON -f --ABI)" \
- sphinx-build doc doc_output || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
- doicon spyderlib/images/spyder.svg || die
- make_desktop_entry spyder Spyder spyder "Development;IDE"
- if use doc; then
- pushd doc_output > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _images _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-}
diff --git a/dev-python/spyder/spyder-2.1.7.ebuild b/dev-python/spyder/spyder-2.1.11.ebuild
index bef9ade1604f..0c7697787d8e 100644
--- a/dev-python/spyder/spyder-2.1.7.ebuild
+++ b/dev-python/spyder/spyder-2.1.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.1.7.ebuild,v 1.1 2012/03/09 09:12:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.1.11.ebuild,v 1.1 2012/08/02 17:50:03 bicatali Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
@@ -15,7 +15,7 @@ SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc ipython matplotlib numpy pep8 +pyflakes pylint +rope scipy sphinx"
RDEPEND=">=dev-python/PyQt4-4.4[webkit]
@@ -29,18 +29,18 @@ RDEPEND=">=dev-python/PyQt4-4.4[webkit]
scipy? ( sci-libs/scipy )
sphinx? ( dev-python/sphinx )"
DEPEND="${RDEPEND}
+ app-arch/unzip
doc? ( dev-python/sphinx )"
PYTHON_MODNAME="spyderlib spyderplugins"
src_prepare() {
distutils_src_prepare
- epatch "${FILESDIR}/${PN}-2.1.2-disable_sphinx_dependency.patch"
+ epatch "${FILESDIR}"/${PN}-2.1.11-disable_sphinx_dependency.patch
}
src_compile() {
distutils_src_compile
-
if use doc; then
einfo "Generation of documentation"
PYTHONPATH="build-$(PYTHON -f --ABI)" \
@@ -50,12 +50,12 @@ src_compile() {
src_install() {
distutils_src_install
- doicon spyderlib/images/spyder.svg || die
+ doicon spyderlib/images/spyder.svg
make_desktop_entry spyder Spyder spyder "Development;IDE"
if use doc; then
pushd doc_output > /dev/null
insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _images _static || die "Installation of documentation failed"
+ doins -r [a-z]* _images _static
popd > /dev/null
fi
}