summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-26 16:22:38 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-26 16:22:38 +0000
commit6afa21ac59280ffe20c49948ec7a9950d55420ad (patch)
tree33d5a9111df72a74588a6b68fe261f8d7ab8aa32 /dev-python/sqlitecachec/sqlitecachec-1.1.4.ebuild
parentDelete older ebuild. (diff)
downloadgentoo-2-6afa21ac59280ffe20c49948ec7a9950d55420ad.tar.gz
gentoo-2-6afa21ac59280ffe20c49948ec7a9950d55420ad.tar.bz2
gentoo-2-6afa21ac59280ffe20c49948ec7a9950d55420ad.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 2.2.0_alpha10_p8/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sqlitecachec/sqlitecachec-1.1.4.ebuild')
-rw-r--r--dev-python/sqlitecachec/sqlitecachec-1.1.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sqlitecachec/sqlitecachec-1.1.4.ebuild b/dev-python/sqlitecachec/sqlitecachec-1.1.4.ebuild
new file mode 100644
index 000000000000..373b896728e3
--- /dev/null
+++ b/dev-python/sqlitecachec/sqlitecachec-1.1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlitecachec/sqlitecachec-1.1.4.ebuild,v 1.1 2010/12/26 16:22:38 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+MY_P="yum-metadata-parser-${PV}"
+
+DESCRIPTION="sqlite cacher for python applications"
+HOMEPAGE="http://yum.baseurl.org/"
+SRC_URI="http://yum.baseurl.org/download/yum-metadata-parser/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="sqlitecachec.py"