summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2015-01-08 18:19:29 +0000
committerBrian Dolbec <dolsen@gentoo.org>2015-01-08 18:19:29 +0000
commitb61197cf6732f7e6cc93e967b039180508ef8375 (patch)
tree7122d1e26b0b8f8bcb9fe594856472bf515d3b58 /dev-python/ssl-fetch
parentFirst release, adjust gnupg dep (diff)
downloadgentoo-2-b61197cf6732f7e6cc93e967b039180508ef8375.tar.gz
gentoo-2-b61197cf6732f7e6cc93e967b039180508ef8375.tar.bz2
gentoo-2-b61197cf6732f7e6cc93e967b039180508ef8375.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x65E309F2189DB0B8)
Diffstat (limited to 'dev-python/ssl-fetch')
-rw-r--r--dev-python/ssl-fetch/ChangeLog9
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-0.3.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-python/ssl-fetch/ChangeLog b/dev-python/ssl-fetch/ChangeLog
index 5985f0e3452e..afc8a825d01e 100644
--- a/dev-python/ssl-fetch/ChangeLog
+++ b/dev-python/ssl-fetch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ssl-fetch
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ssl-fetch/ChangeLog,v 1.26 2014/09/24 09:33:27 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ssl-fetch/ChangeLog,v 1.27 2015/01/08 18:19:29 dolsen Exp $
+
+*ssl-fetch-0.3 (08 Jan 2015)
+
+ 08 Jan 2015; Brian Dolbec <dolsen@gentoo.org> +ssl-fetch-0.3.ebuild:
+ Version bump.
24 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ssl-fetch-0.2.ebuild:
Stable for x86, wrt bug #513278
diff --git a/dev-python/ssl-fetch/ssl-fetch-0.3.ebuild b/dev-python/ssl-fetch/ssl-fetch-0.3.ebuild
new file mode 100644
index 000000000000..739e1a6a5c33
--- /dev/null
+++ b/dev-python/ssl-fetch/ssl-fetch-0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ssl-fetch/ssl-fetch-0.3.ebuild,v 1.1 2015/01/08 18:19:29 dolsen Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A small convinience library for fetching files securely"
+HOMEPAGE="https://github.com/dol-sen/ssl-fetch"
+SRC_URI="http://dev.gentoo.org/~dolsen/releases/ssl-fetch/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x64-macos ~x86-macos"
+
+DEPEND=""
+
+RDEPEND="${DEPEND}
+ >=dev-python/requests-1.2.1[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ dev-python/ndg-httpsclient[python_targets_python2_7]
+ dev-python/pyasn1[python_targets_python2_7]
+ >=dev-python/pyopenssl-0.13[python_targets_python2_7]
+ )
+ "
+
+pkg_postinst() {
+ einfo
+ einfo "This is beta software."
+ einfo "The APIs it installs should be considered unstable"
+ einfo "and are subject to change in these early versions."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/ssl-fetch/issues"
+ einfo "I am also on IRC @ #gentoo-portage, #gentoo-keys,... of the Freenode network"
+ einfo
+}