summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-28 16:46:43 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-28 16:46:43 +0000
commitb7c7a3267852fe8faa691d226d5a0f0d4790aa9f (patch)
tree50dfd543b26d1524bf240d6903435a7bb7e66d6b /dev-python/testify
parentRemove USE=bash-completion, install the completion file unconditionally. Use ... (diff)
downloadgentoo-2-b7c7a3267852fe8faa691d226d5a0f0d4790aa9f.tar.gz
gentoo-2-b7c7a3267852fe8faa691d226d5a0f0d4790aa9f.tar.bz2
gentoo-2-b7c7a3267852fe8faa691d226d5a0f0d4790aa9f.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/testify')
-rw-r--r--dev-python/testify/ChangeLog7
-rw-r--r--dev-python/testify/testify-0.3.6.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/testify/ChangeLog b/dev-python/testify/ChangeLog
index 2c97ed37f7ad..a3216746e066 100644
--- a/dev-python/testify/ChangeLog
+++ b/dev-python/testify/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/testify
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.15 2014/07/24 10:12:30 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.16 2014/08/28 16:46:43 idella4 Exp $
+
+*testify-0.3.6 (28 Aug 2014)
+
+ 28 Aug 2014; Ian Delaney <idella4@gentoo.org> +testify-0.3.6.ebuild:
+ bump
*testify-0.3.5 (24 Jul 2014)
diff --git a/dev-python/testify/testify-0.3.6.ebuild b/dev-python/testify/testify-0.3.6.ebuild
new file mode 100644
index 000000000000..d1d4146195af
--- /dev/null
+++ b/dev-python/testify/testify-0.3.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.6.ebuild,v 1.1 2014/08/28 16:46:43 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+#RESTRICT="test" # basically very broken
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A more pythonic replacement for the unittest module and nose"
+HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
+SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+# There is another undocumented dep req'd for the testsuite; catbox
+DOCS="README.md"
+
+python_prepare_all() {
+ # Correct typo in setup.py
+ sed -e 's:mock,:mock:' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # https://github.com/Yelp/Testify/issues/283
+ "${PYTHON}" bin/${PN} test || die
+}