summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-17 17:44:54 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-17 17:44:54 +0000
commitd1d21ad16e658fc2508a90904fbd6a33a0fbe6f2 (patch)
treee920e22dcf6a46603fb58a9d6b581e4237ed8944 /dev-python/testscenarios
parentVersion bump. Drop ~sparc-fbsd keyword. Remove old. (diff)
downloadgentoo-2-d1d21ad16e658fc2508a90904fbd6a33a0fbe6f2.tar.gz
gentoo-2-d1d21ad16e658fc2508a90904fbd6a33a0fbe6f2.tar.bz2
gentoo-2-d1d21ad16e658fc2508a90904fbd6a33a0fbe6f2.zip
openstack testing, but tests fail...
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/testscenarios')
-rw-r--r--dev-python/testscenarios/ChangeLog9
-rw-r--r--dev-python/testscenarios/metadata.xml16
-rw-r--r--dev-python/testscenarios/testscenarios-0.4.ebuild29
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/testscenarios/ChangeLog b/dev-python/testscenarios/ChangeLog
new file mode 100644
index 000000000000..cf44d6775412
--- /dev/null
+++ b/dev-python/testscenarios/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/testscenarios
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testscenarios/ChangeLog,v 1.1 2013/09/17 17:44:54 prometheanfire Exp $
+
+*testscenarios-0.4 (17 Sep 2013)
+
+ 17 Sep 2013; Matthew Thode <prometheanfire@gentoo.org> +metadata.xml,
+ +testscenarios-0.4.ebuild:
+ openstack testing, but tests fail...
diff --git a/dev-python/testscenarios/metadata.xml b/dev-python/testscenarios/metadata.xml
new file mode 100644
index 000000000000..b82fb1892022
--- /dev/null
+++ b/dev-python/testscenarios/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Testscenarios provides clean dependency injection for
+ python unittest style tests. This can be used for interface testing
+ (testing many implementations via a single test suite) or for classic
+ dependency injection (provide tests with dependencies externally to the
+ test code itself, allowing easy testing in different situations).
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/testscenarios/testscenarios-0.4.ebuild b/dev-python/testscenarios/testscenarios-0.4.ebuild
new file mode 100644
index 000000000000..02a654080c52
--- /dev/null
+++ b/dev-python/testscenarios/testscenarios-0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testscenarios/testscenarios-0.4.ebuild,v 1.1 2013/09/17 17:44:54 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="Testscenarios, a pyunit extension for dependency injection"
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/testresources[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" setup.py nosetests || die
+}