summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-09 13:31:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-09 13:31:29 +0000
commita6a6db7f360c2e5b2645f53e34aa0a0c6f14ad7e (patch)
tree4e2e3a20dff8c7c8d76af805129d268a4fc2c78c /dev-python/traits
parentConvert gtk-query-immodules-gtk2 into safe usage. #413527 (diff)
downloadgentoo-2-a6a6db7f360c2e5b2645f53e34aa0a0c6f14ad7e.tar.gz
gentoo-2-a6a6db7f360c2e5b2645f53e34aa0a0c6f14ad7e.tar.bz2
gentoo-2-a6a6db7f360c2e5b2645f53e34aa0a0c6f14ad7e.zip
Bump
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/traits')
-rw-r--r--dev-python/traits/ChangeLog7
-rw-r--r--dev-python/traits/traits-4.2.0.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/traits/ChangeLog b/dev-python/traits/ChangeLog
index 02ff682280a1..2f02ce07344a 100644
--- a/dev-python/traits/ChangeLog
+++ b/dev-python/traits/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/traits
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/ChangeLog,v 1.30 2012/08/22 23:04:01 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/ChangeLog,v 1.31 2012/10/09 13:31:29 patrick Exp $
+
+*traits-4.2.0 (09 Oct 2012)
+
+ 09 Oct 2012; Patrick Lauer <patrick@gentoo.org> +traits-4.2.0.ebuild:
+ Bump
22 Aug 2012; Michael Weber <xmw@gentoo.org> traits-4.1.0.ebuild:
ppc stable (bug 418923).
diff --git a/dev-python/traits/traits-4.2.0.ebuild b/dev-python/traits/traits-4.2.0.ebuild
new file mode 100644
index 000000000000..6ebfb34ebfac
--- /dev/null
+++ b/dev-python/traits/traits-4.2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-4.2.0.ebuild,v 1.1 2012/10/09 13:31:29 patrick Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
+HOMEPAGE="http://code.enthought.com/projects/traits/ http://pypi.python.org/pypi/traits"
+SRC_URI="http://www.enthought.com/repo/ETS/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/numpy"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/numpy )"
+
+DOCS="docs/*.txt"
+
+src_prepare() {
+ sed -i -e "s/'-O3'//g" setup.py
+}
+
+src_compile() {
+ distutils_src_compile
+ use doc && virtualmake -C docs html
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}