summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-06-26 22:18:10 +0000
committerMarien Zwart <marienz@gentoo.org>2006-06-26 22:18:10 +0000
commit600cb158d74a0e95c3f6d726702d6419dd6b017b (patch)
treee1ba8480a5687d97f1e1bba329a87da7d789969a /dev-python/twisted-lore
parentFixing ChangeLog and Manifest. Upstream keeps changing these files, because ... (diff)
downloadgentoo-2-600cb158d74a0e95c3f6d726702d6419dd6b017b.tar.gz
gentoo-2-600cb158d74a0e95c3f6d726702d6419dd6b017b.tar.bz2
gentoo-2-600cb158d74a0e95c3f6d726702d6419dd6b017b.zip
Do not call "which" to check for dia (bug #128688).
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'dev-python/twisted-lore')
-rw-r--r--dev-python/twisted-lore/ChangeLog8
-rw-r--r--dev-python/twisted-lore/files/digest-twisted-lore-0.1.0-r23
-rw-r--r--dev-python/twisted-lore/files/twisted-lore-0.1.0-which.patch22
-rw-r--r--dev-python/twisted-lore/twisted-lore-0.1.0-r2.ebuild23
4 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/twisted-lore/ChangeLog b/dev-python/twisted-lore/ChangeLog
index 83ee9a13300d..cee78e1d1814 100644
--- a/dev-python/twisted-lore/ChangeLog
+++ b/dev-python/twisted-lore/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twisted-lore
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/ChangeLog,v 1.10 2006/05/26 18:43:37 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/ChangeLog,v 1.11 2006/06/26 22:18:10 marienz Exp $
+
+*twisted-lore-0.1.0-r2 (26 Jun 2006)
+
+ 26 Jun 2006; Marien Zwart <marienz@gentoo.org>
+ +files/twisted-lore-0.1.0-which.patch, +twisted-lore-0.1.0-r2.ebuild:
+ Do not call "which" to check for dia (bug #128688).
*twisted-lore-0.2.0 (26 May 2006)
diff --git a/dev-python/twisted-lore/files/digest-twisted-lore-0.1.0-r2 b/dev-python/twisted-lore/files/digest-twisted-lore-0.1.0-r2
new file mode 100644
index 000000000000..082c1b572f8c
--- /dev/null
+++ b/dev-python/twisted-lore/files/digest-twisted-lore-0.1.0-r2
@@ -0,0 +1,3 @@
+MD5 c38eea006be598081778d79c98fc8a42 TwistedLore-0.1.0.tar.bz2 58386
+RMD160 755df5830fab00d71bcdf4878d77fcec533a1eac TwistedLore-0.1.0.tar.bz2 58386
+SHA256 5a2a61423ab091ac4f7e2877987c420d3701c8960d2312ddd17f410dd5b7fe92 TwistedLore-0.1.0.tar.bz2 58386
diff --git a/dev-python/twisted-lore/files/twisted-lore-0.1.0-which.patch b/dev-python/twisted-lore/files/twisted-lore-0.1.0-which.patch
new file mode 100644
index 000000000000..cae970f2dd09
--- /dev/null
+++ b/dev-python/twisted-lore/files/twisted-lore-0.1.0-which.patch
@@ -0,0 +1,22 @@
+Index: /trunk/twisted/lore/latex.py
+===================================================================
+--- /trunk/twisted/lore/latex.py (revision 11450)
++++ /trunk/twisted/lore/latex.py (revision 13880)
+@@ -5,5 +5,5 @@
+
+ from twisted.web import microdom, domhelpers
+-from twisted.python import text
++from twisted.python import text, procutils
+ import os, os.path, re, string
+ from cStringIO import StringIO
+@@ -104,9 +104,5 @@
+
+ baseLevel = 0
+- try:
+- diaHack = not not os.popen('which dia').read()
+- except:
+- # That's a no, then.
+- diaHack = 0
++ diaHack = bool(procutils.which("dia"))
+
+ def writeNodeData(self, node):
diff --git a/dev-python/twisted-lore/twisted-lore-0.1.0-r2.ebuild b/dev-python/twisted-lore/twisted-lore-0.1.0-r2.ebuild
new file mode 100644
index 000000000000..eda785ae335a
--- /dev/null
+++ b/dev-python/twisted-lore/twisted-lore-0.1.0-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/twisted-lore-0.1.0-r2.ebuild,v 1.1 2006/06/26 22:18:10 marienz Exp $
+
+MY_PACKAGE=Lore
+
+inherit twisted eutils
+
+DESCRIPTION="Twisted documentation system"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-python/twisted-2
+ <dev-python/twisted-2.4
+ dev-python/twisted-web"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # use python to figure out if dia is available instead of calling "which"
+ epatch "${FILESDIR}/${P}-which.patch"
+}