summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-06-26 21:13:51 +0000
committerMarien Zwart <marienz@gentoo.org>2006-06-26 21:13:51 +0000
commit0f85619cebef03ec40f0d9c77aa83dd575613de2 (patch)
tree753948b785ae8778d26f5f3975b8205fd61d7b27 /dev-python/twisted-web/twisted-web-0.5.0-r3.ebuild
parentarm/ia64/s390/sh stable #137143 (diff)
downloadgentoo-2-0f85619cebef03ec40f0d9c77aa83dd575613de2.tar.gz
gentoo-2-0f85619cebef03ec40f0d9c77aa83dd575613de2.tar.bz2
gentoo-2-0f85619cebef03ec40f0d9c77aa83dd575613de2.zip
Remove twisted-web-0.5.0-r2 (the version with extra test patches for twisted-2.2.0): use twisted-2.4.0 and web 0.6.0 instead. Add new revisions with the nonworking websetroot removed.
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'dev-python/twisted-web/twisted-web-0.5.0-r3.ebuild')
-rw-r--r--dev-python/twisted-web/twisted-web-0.5.0-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/twisted-web/twisted-web-0.5.0-r3.ebuild b/dev-python/twisted-web/twisted-web-0.5.0-r3.ebuild
new file mode 100644
index 000000000000..62972be2a3ae
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-0.5.0-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-0.5.0-r3.ebuild,v 1.1 2006/06/26 21:13:50 marienz Exp $
+
+MY_PACKAGE=Web
+
+inherit twisted eutils
+
+DESCRIPTION="Twisted web server, programmable in Python"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sh ~sparc ~x86"
+
+DEPEND=">=dev-python/twisted-2
+ <dev-python/twisted-2.4"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-root-skip.patch"
+ epatch "${FILESDIR}/${P}-tests-2.2-compat.patch"
+}
+
+src_install() {
+ twisted_src_install
+
+ # Get rid of the main user-visible bits of websetroots: the
+ # wrapper script in bin and the manpage. This leaves behind the
+ # script in scripts in site-packages. websetroot is removed
+ # entirely in upstream svn and does not work in this version.
+ rm -rf "${D}"/usr/{bin,share/man}
+}