summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-10 12:42:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-10 12:42:49 +0000
commit6e820a587f8e9a3d1bcdff404bb6afd8ed1f078b (patch)
treee8d14ea4f4a5ae9064597050e8b58237b7690891 /dev-python/webtest
parentMove libzfs_core to / too (diff)
downloadgentoo-2-6e820a587f8e9a3d1bcdff404bb6afd8ed1f078b.tar.gz
gentoo-2-6e820a587f8e9a3d1bcdff404bb6afd8ed1f078b.tar.bz2
gentoo-2-6e820a587f8e9a3d1bcdff404bb6afd8ed1f078b.zip
Bump
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/ChangeLog7
-rw-r--r--dev-python/webtest/webtest-2.0.7.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/webtest/ChangeLog b/dev-python/webtest/ChangeLog
index e5066e6c360b..268a020d013a 100644
--- a/dev-python/webtest/ChangeLog
+++ b/dev-python/webtest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webtest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.60 2013/06/03 06:22:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.61 2013/08/10 12:42:49 patrick Exp $
+
+*webtest-2.0.7 (10 Aug 2013)
+
+ 10 Aug 2013; Patrick Lauer <patrick@gentoo.org> +webtest-2.0.7.ebuild:
+ Bump
*webtest-2.0.6 (03 Jun 2013)
diff --git a/dev-python/webtest/webtest-2.0.7.ebuild b/dev-python/webtest/webtest-2.0.7.ebuild
new file mode 100644
index 000000000000..70350b8b97a3
--- /dev/null
+++ b/dev-python/webtest/webtest-2.0.7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-2.0.7.ebuild,v 1.1 2013/08/10 12:42:49 patrick Exp $
+
+EAPI=5
+
+# sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_TESTS_RESTRICTED_ABIS="3.*"
+
+inherit distutils-r1
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/webob-0.9.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ dev-python/waitress[${PYTHON_USEDEP}]
+ dev-python/wsgiproxy2[${PYTHON_USEDEP}]
+ dev-python/paste
+ dev-python/pastedeploy )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die
+ fi
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Why is it so?
+ if [[ ${EPYTHON} == python3* ]]; then
+ rm -f "${D}$(python_get_sitedir)"/webtest/lint3.py
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+ distutils-r1_python_install_all
+}