summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-26 08:15:08 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-26 08:15:08 +0000
commitb5ab43f82ff2103451883c0e6391a98c1812a92a (patch)
tree45a7da854a7d66909dbc4b0d67969f73c163a93c /dev-python/wtforms
parentBump (diff)
downloadgentoo-2-b5ab43f82ff2103451883c0e6391a98c1812a92a.tar.gz
gentoo-2-b5ab43f82ff2103451883c0e6391a98c1812a92a.tar.bz2
gentoo-2-b5ab43f82ff2103451883c0e6391a98c1812a92a.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/wtforms')
-rw-r--r--dev-python/wtforms/ChangeLog7
-rw-r--r--dev-python/wtforms/wtforms-2.0.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/wtforms/ChangeLog b/dev-python/wtforms/ChangeLog
index 4c5cb98002a2..33ce3b2c8ef0 100644
--- a/dev-python/wtforms/ChangeLog
+++ b/dev-python/wtforms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wtforms
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.35 2014/03/31 20:54:48 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.36 2014/05/26 08:15:08 patrick Exp $
+
+*wtforms-2.0 (26 May 2014)
+
+ 26 May 2014; Patrick Lauer <patrick@gentoo.org> +wtforms-2.0.ebuild:
+ Bump
31 Mar 2014; Michał Górny <mgorny@gentoo.org> wtforms-1.0.3-r1.ebuild,
wtforms-1.0.4.ebuild, wtforms-1.0.5.ebuild:
diff --git a/dev-python/wtforms/wtforms-2.0.ebuild b/dev-python/wtforms/wtforms-2.0.ebuild
new file mode 100644
index 000000000000..b7d1dd9e6f52
--- /dev/null
+++ b/dev-python/wtforms/wtforms-2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-2.0.ebuild,v 1.1 2014/05/26 08:15:08 patrick Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN="WTForms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="app-arch/unzip
+ doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS="AUTHORS.txt CHANGES.txt README.txt"
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Building of documentation failed"
+ fi
+}
+
+python_install_all() {
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}