summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-28 13:56:51 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-28 13:56:51 +0000
commitdf2b6826b04ed6be6af5d41180b57b7f0e98dbfd (patch)
treec36a181a58c4f0d09f1b59b0c00ce61fe4b1c25c /dev-python/wxpython
parentTest needs manual intervention, so RESTRICT=test (Bug #284168) (diff)
downloadgentoo-2-df2b6826b04ed6be6af5d41180b57b7f0e98dbfd.tar.gz
gentoo-2-df2b6826b04ed6be6af5d41180b57b7f0e98dbfd.tar.bz2
gentoo-2-df2b6826b04ed6be6af5d41180b57b7f0e98dbfd.zip
Don't ignore errors.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/wxpython-2.6.4.0-r2.ebuild6
-rw-r--r--dev-python/wxpython/wxpython-2.8.10.1.ebuild4
-rw-r--r--dev-python/wxpython/wxpython-2.8.11.0.ebuild4
3 files changed, 7 insertions, 7 deletions
diff --git a/dev-python/wxpython/wxpython-2.6.4.0-r2.ebuild b/dev-python/wxpython/wxpython-2.6.4.0-r2.ebuild
index 5e672ab5fea9..8156d0e38510 100644
--- a/dev-python/wxpython/wxpython-2.6.4.0-r2.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.4.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r2.ebuild,v 1.13 2010/07/27 03:13:09 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r2.ebuild,v 1.14 2010/07/28 13:56:51 arfrever Exp $
EAPI="2"
PYTHON_DEPEND="2"
@@ -88,12 +88,12 @@ src_install() {
rename_files() {
for file in "${D}$(python_get_sitedir)"/wx{version.*,.pth}; do
- mv "${file}" "${file}-${SLOT}"
+ mv "${file}" "${file}-${SLOT}" || return 1
done
for dir in "${D}$(python_get_sitedir)"/wx-${SLOT}-gtk2-{ansi,unicode}; do
if [[ -d ${dir} ]]; then
- cp -R "${D}$(python_get_sitedir)"/wxaddons/ "${dir}"
+ cp -R "${D}$(python_get_sitedir)"/wxaddons/ "${dir}" || return 1
wxaddons_copied=1
fi
done
diff --git a/dev-python/wxpython/wxpython-2.8.10.1.ebuild b/dev-python/wxpython/wxpython-2.8.10.1.ebuild
index faf24db98dd4..897321a9bae7 100644
--- a/dev-python/wxpython/wxpython-2.8.10.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.10.1.ebuild,v 1.15 2010/07/27 03:13:09 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.10.1.ebuild,v 1.16 2010/07/28 13:56:51 arfrever Exp $
EAPI="2"
PYTHON_DEPEND="2"
@@ -104,7 +104,7 @@ src_install() {
done
rename_files() {
for file in "${D}$(python_get_sitedir)/"wx{version.*,.pth}; do
- mv "${file}" "${file}-${SLOT}"
+ mv "${file}" "${file}-${SLOT}" || return 1
done
}
python_execute_function -q rename_files
diff --git a/dev-python/wxpython/wxpython-2.8.11.0.ebuild b/dev-python/wxpython/wxpython-2.8.11.0.ebuild
index 8f95c30ea6bd..b048b2cbcb46 100644
--- a/dev-python/wxpython/wxpython-2.8.11.0.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.11.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.11.0.ebuild,v 1.1 2010/05/27 05:20:41 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.11.0.ebuild,v 1.2 2010/07/28 13:56:51 arfrever Exp $
EAPI="2"
PYTHON_DEPEND="2"
@@ -104,7 +104,7 @@ src_install() {
done
rename_files() {
for file in "${D}$(python_get_sitedir)/"wx{version.*,.pth}; do
- mv "${file}" "${file}-${SLOT}"
+ mv "${file}" "${file}-${SLOT}" || return 1
done
}
python_execute_function -q rename_files