summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-04-22 05:56:08 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-04-22 05:56:08 +0000
commitf24f1d5e59c7088479d39fc6a0099250b0c3527f (patch)
tree9bf1bcdf2b9eab8029c9b53d98775b688521b8e1 /dev-python/wxpython
parentRemove virtuals file, it is redundant with the one in the base profile. (diff)
downloadgentoo-2-f24f1d5e59c7088479d39fc6a0099250b0c3527f.tar.gz
gentoo-2-f24f1d5e59c7088479d39fc6a0099250b0c3527f.tar.bz2
gentoo-2-f24f1d5e59c7088479d39fc6a0099250b0c3527f.zip
Don't install non-working binary stuff into DOCDIR (bug #364393 by ago).
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/ChangeLog6
-rw-r--r--dev-python/wxpython/wxpython-2.8.11.0.ebuild3
-rw-r--r--dev-python/wxpython/wxpython-2.8.12.0.ebuild16
3 files changed, 17 insertions, 8 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index f7505b500843..18289dbc3faf 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/wxpython
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.142 2011/04/20 07:45:23 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.143 2011/04/22 05:56:08 dirtyepic Exp $
+
+ 22 Apr 2011; Ryan Hill <dirtyepic@gentoo.org> wxpython-2.8.11.0.ebuild,
+ wxpython-2.8.12.0.ebuild:
+ Don't install non-working binary stuff into DOCDIR (bug #364393 by ago).
*wxpython-2.8.12.0 (20 Apr 2011)
diff --git a/dev-python/wxpython/wxpython-2.8.11.0.ebuild b/dev-python/wxpython/wxpython-2.8.11.0.ebuild
index ba3dba46c8b7..05403f905ef2 100644
--- a/dev-python/wxpython/wxpython-2.8.11.0.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.11.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.11.0.ebuild,v 1.5 2011/04/21 01:20:09 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.11.0.ebuild,v 1.6 2011/04/22 05:56:08 dirtyepic Exp $
EAPI="2"
PYTHON_DEPEND="2"
@@ -129,6 +129,7 @@ src_install() {
dodir /usr/share/doc/${PF}/samples
cp -R "${DOC_S}"/demo/* "${D}"/usr/share/doc/${PF}/demo/
cp -R "${DOC_S}"/samples/* "${D}"/usr/share/doc/${PF}/samples/
+ rm -f "${D}"usr/share/doc/${PF}/samples/embedded/embedded
fi
}
diff --git a/dev-python/wxpython/wxpython-2.8.12.0.ebuild b/dev-python/wxpython/wxpython-2.8.12.0.ebuild
index 05dceba482af..93c2fb1dc393 100644
--- a/dev-python/wxpython/wxpython-2.8.12.0.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.12.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.0.ebuild,v 1.2 2011/04/21 01:20:09 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.0.ebuild,v 1.3 2011/04/22 05:56:08 dirtyepic Exp $
EAPI="2"
PYTHON_DEPEND="2"
@@ -84,7 +84,7 @@ src_compile() {
}
src_install() {
- local mypyconf
+ local docdir mypyconf
mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \
@@ -117,18 +117,22 @@ src_install() {
newins "${S}"/wx/py/PyCrust_32.png PyCrust.png
newins "${S}"/wx/tools/XRCed/XRCed_32.png XRCed.png
+ docdir=${D}usr/share/doc/${PF}
+
if use doc; then
dodir /usr/share/doc/${PF}/docs
- cp -R "${DOC_S}"/docs/* "${D}"usr/share/doc/${PF}/docs/
+ cp -R "${DOC_S}"/docs/* "${docdir}"/docs/
# For some reason newer API docs aren't available so use 2.8.9.2's
- cp -R "${WORKDIR}"/wxPython-2.8.9.2/docs/* "${D}"usr/share/doc/${PF}/docs/
+ cp -R "${WORKDIR}"/wxPython-2.8.9.2/docs/* "${docdir}"/docs/
fi
if use examples; then
dodir /usr/share/doc/${PF}/demo
+ cp -R "${DOC_S}"/demo/* "${docdir}"/demo
dodir /usr/share/doc/${PF}/samples
- cp -R "${DOC_S}"/demo/* "${D}"/usr/share/doc/${PF}/demo/
- cp -R "${DOC_S}"/samples/* "${D}"/usr/share/doc/${PF}/samples/
+ cp -R "${DOC_S}"/samples/* "${docdir}"/samples
+ [[ -e ${docdir}/samples/embedded/embedded ]] \
+ && rm -f "${docdir}"/samples/embedded/embedded
fi
}