summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-18 11:02:36 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-18 11:02:36 +0000
commit07006ca411e445fd3bdb7cfdebefa4fd6613865c (patch)
tree54c1bfb418bb011a4f2b4353ccec152b2dffceff /dev-python
parentmake it work with userpriv (diff)
downloadgentoo-2-07006ca411e445fd3bdb7cfdebefa4fd6613865c.tar.gz
gentoo-2-07006ca411e445fd3bdb7cfdebefa4fd6613865c.tar.bz2
gentoo-2-07006ca411e445fd3bdb7cfdebefa4fd6613865c.zip
moved from dev-python/4Suite to dev-python/4suite, also revamped stable 0.11.1 to use distutils
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/4suite/4suite-0.11.1.ebuild27
-rw-r--r--dev-python/4suite/4suite-1.0_alpha3.ebuild23
-rw-r--r--dev-python/4suite/ChangeLog44
-rw-r--r--dev-python/4suite/files/digest-4suite-0.11.11
-rw-r--r--dev-python/4suite/files/digest-4suite-1.0_alpha31
-rw-r--r--dev-python/4suite/metadata.xml5
6 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/4suite/4suite-0.11.1.ebuild b/dev-python/4suite/4suite-0.11.1.ebuild
new file mode 100644
index 000000000000..25b09a7d9f1f
--- /dev/null
+++ b/dev-python/4suite/4suite-0.11.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/4suite-0.11.1.ebuild,v 1.1 2004/01/18 11:02:36 liquidx Exp $
+
+inherit distutils
+
+MY_P=${P/4s/4S}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Python tools for XML processing and object-databases."
+SRC_URI="ftp://ftp.4suite.org/pub/4Suite/old/4Suite/${PV}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.4suite.org/"
+
+DEPEND="virtual/python
+ >=dev-python/pyxml-0.6.5"
+RDEPEND="${RDEPEND}"
+
+SLOT="0"
+KEYWORDS="x86 sparc alpha ~ppc"
+LICENSE="Apache-1.1"
+
+PYTHON_MODNAME="Ft _xmlplus"
+
+src_install() {
+ distutils_src_install
+ rm -rf ${D}/usr/share/doc/${PF}
+ mv ${D}/usr/doc/${MY_P} ${D}/usr/share/doc/${PF}
+}
diff --git a/dev-python/4suite/4suite-1.0_alpha3.ebuild b/dev-python/4suite/4suite-1.0_alpha3.ebuild
new file mode 100644
index 000000000000..124be11e34a0
--- /dev/null
+++ b/dev-python/4suite/4suite-1.0_alpha3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/4suite-1.0_alpha3.ebuild,v 1.1 2004/01/18 11:02:36 liquidx Exp $
+
+inherit distutils
+
+MY_P=${P/4s/4S}
+MY_P=${MY_P/_alpha/a}
+S=${WORKDIR}/4Suite
+DESCRIPTION="Python tools for XML processing and object-databases."
+SRC_URI="ftp://ftp.4suite.org/pub/4Suite/${MY_P}.tar.gz"
+HOMEPAGE="http://www.4suite.org/"
+
+DEPEND=">=dev-python/pyxml-0.6.5"
+RDEPEND="${RDEPEND}"
+
+SLOT="0"
+KEYWORDS="x86 ~sparc ~alpha ~ppc"
+LICENSE="Apache-1.1"
+
+PYTHON_MODNAME="Ft"
+DOCS="docs/*.txt"
+
diff --git a/dev-python/4suite/ChangeLog b/dev-python/4suite/ChangeLog
new file mode 100644
index 000000000000..9a5831705263
--- /dev/null
+++ b/dev-python/4suite/ChangeLog
@@ -0,0 +1,44 @@
+# ChangeLog for dev-python/4suite
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/ChangeLog,v 1.1 2004/01/18 11:02:36 liquidx Exp $
+
+ 18 Jan 2004; Alastair Tse <liquidx@gentoo.org> 4suite-0.11.1.ebuild,
+ 4suite-1.0_alpha3.ebuild, metadata.xml:
+ moved from dev-python/4Suite to dev-python/4suite, also revamped stable 0.11.1
+ to use distutils
+
+*4Suite-1.0_alpha3 (03 Sep 2003)
+
+ 03 Sep 2003; Alastair Tse <liquidx@gentoo.org> 4Suite-1.0_alpha3.ebuild:
+ version bump. changed . (#27199)
+
+*4Suite-1.0_alpha1 (20 Apr 2003)
+
+ 20 Apr 2003; Bart Lauwers <blauwers@gentoo.org> :
+ Version bump per bug #12760 and ebuild clean-up
+
+*4Suite-0.11.1 (18 Mar 2002)
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
+ 17 Mar 2003; Graham Forest <vladimir@gentoo.org> 4Suite-0.11.1.ebuild:
+ set ~ppc in keywords
+
+ 26 Jul 2002; George Shapovalov <george@gentoo.org> 4Suite-0.11.1.ebuild :
+ added KEYWORDS,SLOT,LICENSE
+
+ 18 Mar 2002; Seemant Kulleen <seemant@gentoo.org> 4Suite-0.11.1 :
+
+ Version upgrade and made a dependency on dev-python/PyXML >= instead of = to
+ keep up with upgrades of that, thanks to bs@wasd.dk (Bjarke S?rensen).
+
+
+*4Suite-0.11.1_beta3 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/dev-python/4suite/files/digest-4suite-0.11.1 b/dev-python/4suite/files/digest-4suite-0.11.1
new file mode 100644
index 000000000000..9c0abaaf2645
--- /dev/null
+++ b/dev-python/4suite/files/digest-4suite-0.11.1
@@ -0,0 +1 @@
+MD5 169274870a10c233851383faa7a9eddb 4Suite-0.11.1.tar.gz 1396667
diff --git a/dev-python/4suite/files/digest-4suite-1.0_alpha3 b/dev-python/4suite/files/digest-4suite-1.0_alpha3
new file mode 100644
index 000000000000..8be745a6a2e3
--- /dev/null
+++ b/dev-python/4suite/files/digest-4suite-1.0_alpha3
@@ -0,0 +1 @@
+MD5 3f08362a8834f7fc971c090842777dea 4Suite-1.0a3.tar.gz 2345943
diff --git a/dev-python/4suite/metadata.xml b/dev-python/4suite/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/4suite/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>