summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-08 20:30:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-08 20:30:29 +0000
commit08f19d9e9cb37c87d2c9dbffbed3a89aaf333f76 (patch)
tree1637747ebbb509512882439866644d6b0e5d6220 /dev-python
parentDelete older ebuilds. (diff)
downloadgentoo-2-08f19d9e9cb37c87d2c9dbffbed3a89aaf333f76.tar.gz
gentoo-2-08f19d9e9cb37c87d2c9dbffbed3a89aaf333f76.tar.bz2
gentoo-2-08f19d9e9cb37c87d2c9dbffbed3a89aaf333f76.zip
Restrict CPython-{2.4,2.5} and Jython ABIs.
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/kiwi/ChangeLog8
-rw-r--r--dev-python/kiwi/kiwi-1.9.26.ebuild10
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-python/kiwi/ChangeLog b/dev-python/kiwi/ChangeLog
index 77345b6677d7..43a00670600b 100644
--- a/dev-python/kiwi/ChangeLog
+++ b/dev-python/kiwi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/kiwi
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.13 2009/10/10 17:26:06 grobian Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.14 2011/01/08 20:30:29 arfrever Exp $
+
+ 08 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ kiwi-1.9.26.ebuild:
+ Restrict CPython-{2.4,2.5} and Jython ABIs.
10 Oct 2009; Fabian Groffen <grobian@gentoo.org> kiwi-1.9.26.ebuild:
Merge from Prefix
diff --git a/dev-python/kiwi/kiwi-1.9.26.ebuild b/dev-python/kiwi/kiwi-1.9.26.ebuild
index 39f50bd1aac0..3217b87509bd 100644
--- a/dev-python/kiwi/kiwi-1.9.26.ebuild
+++ b/dev-python/kiwi/kiwi-1.9.26.ebuild
@@ -1,25 +1,25 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/kiwi-1.9.26.ebuild,v 1.3 2010/05/26 14:25:35 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/kiwi-1.9.26.ebuild,v 1.4 2011/01/08 20:30:29 arfrever Exp $
EAPI="3"
-PYTHON_DEPEND="2"
+PYTHON_DEPEND="2:2.6"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython"
inherit distutils versionator
DESCRIPTION="Kiwi is a pure Python framework and set of enhanced PyGTK widgets"
HOMEPAGE="http://www.async.com.br/projects/kiwi/"
SRC_URI="http://download.gnome.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+
LICENSE="LGPL-2.1"
SLOT="0"
-
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-interix ~amd64-linux ~x86-linux"
IUSE="examples"
DEPEND="dev-python/pygtk"
RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
src_prepare() {
distutils_src_prepare