summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-24 23:23:49 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-24 23:23:49 +0000
commit1be9adf29619d15b10c0173f88291e2c0146a7fe (patch)
treeb5ff23f58754808ee5d2c3ed2778edce67ad964b /dev-python
parentDelete older ebuild. (diff)
downloadgentoo-2-1be9adf29619d15b10c0173f88291e2c0146a7fe.tar.gz
gentoo-2-1be9adf29619d15b10c0173f88291e2c0146a7fe.tar.bz2
gentoo-2-1be9adf29619d15b10c0173f88291e2c0146a7fe.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 15152-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycdio/ChangeLog10
-rw-r--r--dev-python/pycdio/pycdio-0.16.ebuild54
2 files changed, 62 insertions, 2 deletions
diff --git a/dev-python/pycdio/ChangeLog b/dev-python/pycdio/ChangeLog
index 54cbbb0d2b16..0c0469287bf4 100644
--- a/dev-python/pycdio/ChangeLog
+++ b/dev-python/pycdio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pycdio
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdio/ChangeLog,v 1.5 2008/05/29 14:21:17 hawking Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdio/ChangeLog,v 1.6 2009/12/24 23:23:49 arfrever Exp $
+
+*pycdio-0.16 (25 Dec 2009)
+
+ 25 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pycdio-0.16.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
29 May 2008; Ali Polatel <hawking@gentoo.org> pycdio-0.13.ebuild:
python_mod_compile is ROOT aware and can take multiple file arguments.
diff --git a/dev-python/pycdio/pycdio-0.16.ebuild b/dev-python/pycdio/pycdio-0.16.ebuild
new file mode 100644
index 000000000000..352efeb81a5d
--- /dev/null
+++ b/dev-python/pycdio/pycdio-0.16.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdio/pycdio-0.16.ebuild,v 1.1 2009/12/24 23:23:49 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python OO interface to libcdio (CD Input and Control library)"
+HOMEPAGE="http://savannah.gnu.org/projects/libcdio/ http://pypi.python.org/pypi/pycdio"
+SRC_URI="http://ftp.gnu.org/gnu/libcdio/${P}.tar.gz http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-libs/libcdio"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+DOCS="README.txt"
+PYTHON_MODNAME="cdio.py iso9660.py pycdio.py pyiso9660.py"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Remove obsolete sys.path and adjust 'data' path in examples.
+ sed -i -e "s:^sys.path.insert.*::" -e "s:\.\./data:./data:g" example/*.py || die "sed failed"
+
+ # Disable failing test.
+ sed -e "s/test_get_set/_&/" -i test/test-cdtext.py || die "sed failed"
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}
+
+src_install(){
+ distutils_src_install
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/examples
+ doins example/{README,*.py}
+ doins -r data
+ fi
+}