summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-05-30 01:33:05 +0000
committerMike Gilbert <floppym@gentoo.org>2014-05-30 01:33:05 +0000
commit21e5f1686507686276887c7b05e273f4c1cd9211 (patch)
tree2e38b04a2b7c34619725b5e46eda4b0e31ad36a8 /dev-python
parentbump, rm oldies (diff)
downloadgentoo-2-21e5f1686507686276887c7b05e273f4c1cd9211.tar.gz
gentoo-2-21e5f1686507686276887c7b05e273f4c1cd9211.tar.bz2
gentoo-2-21e5f1686507686276887c7b05e273f4c1cd9211.zip
Don't install test package, thanks to Arfrever.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/html2text/ChangeLog9
-rw-r--r--dev-python/html2text/files/html2text-noinstall-test.patch35
-rw-r--r--dev-python/html2text/html2text-2014.4.5-r1.ebuild (renamed from dev-python/html2text/html2text-2014.4.5.ebuild)5
3 files changed, 46 insertions, 3 deletions
diff --git a/dev-python/html2text/ChangeLog b/dev-python/html2text/ChangeLog
index debbf68629f9..de91ec751ad7 100644
--- a/dev-python/html2text/ChangeLog
+++ b/dev-python/html2text/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/html2text
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/html2text/ChangeLog,v 1.13 2014/04/21 21:24:08 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html2text/ChangeLog,v 1.14 2014/05/30 01:33:05 floppym Exp $
+
+*html2text-2014.4.5-r1 (30 May 2014)
+
+ 30 May 2014; Mike Gilbert <floppym@gentoo.org>
+ +files/html2text-noinstall-test.patch, +html2text-2014.4.5-r1.ebuild,
+ -html2text-2014.4.5.ebuild:
+ Don't install test package, thanks to Arfrever.
*html2text-2014.4.5 (21 Apr 2014)
diff --git a/dev-python/html2text/files/html2text-noinstall-test.patch b/dev-python/html2text/files/html2text-noinstall-test.patch
new file mode 100644
index 000000000000..70068a847234
--- /dev/null
+++ b/dev-python/html2text/files/html2text-noinstall-test.patch
@@ -0,0 +1,35 @@
+From e4d46b478f78c4464c7b35058154948c928a013b Mon Sep 17 00:00:00 2001
+From: Arfrever <arfrever@github.com>
+Date: Thu, 29 May 2014 18:07:21 +0200
+Subject: [PATCH] Don't install tests (but include them in PyPI package).
+
+Fixes #9
+---
+ MANIFEST.in | 1 +
+ setup.py | 1 -
+ 2 files changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/MANIFEST.in b/MANIFEST.in
+index 1845310..6217360 100644
+--- a/MANIFEST.in
++++ b/MANIFEST.in
+@@ -2,3 +2,4 @@ include COPYING
+ include README.md
+ include ChangeLog.rst
+ include AUTHORS.rst
++recursive-include test *.html *.md *.py
+diff --git a/setup.py b/setup.py
+index 3b7085d..0b2cf08 100644
+--- a/setup.py
++++ b/setup.py
+@@ -65,7 +65,6 @@ def run(self):
+ """,
+ license='GNU GPL 3',
+ requires=requires_list,
+- packages=find_packages(),
+ py_modules=['html2text'],
+ include_package_data=True,
+ zip_safe=False,
+--
+1.9.3
+
diff --git a/dev-python/html2text/html2text-2014.4.5.ebuild b/dev-python/html2text/html2text-2014.4.5-r1.ebuild
index ed5c6c889ac3..6e5af7baf89a 100644
--- a/dev-python/html2text/html2text-2014.4.5.ebuild
+++ b/dev-python/html2text/html2text-2014.4.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/html2text/html2text-2014.4.5.ebuild,v 1.1 2014/04/21 21:24:08 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html2text/html2text-2014.4.5-r1.ebuild,v 1.1 2014/05/30 01:33:05 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_{2,3}} pypy pypy2_0 )
@@ -22,7 +22,8 @@ RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-rename.patch" )
+PATCHES=( "${FILESDIR}/${PN}-rename.patch"
+ "${FILESDIR}/${PN}-noinstall-test.patch" )
src_test() {
impl_specific() {