summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-31 21:53:40 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-31 21:53:40 +0000
commit24ff1d049d8e2b04eeb2c7d60c3c43d25c7668f8 (patch)
tree5a1fd951f92886203b52c6ec0d7f31a4a25ea8ae /dev-python
parentDelete older ebuild. (diff)
downloadgentoo-2-24ff1d049d8e2b04eeb2c7d60c3c43d25c7668f8.tar.gz
gentoo-2-24ff1d049d8e2b04eeb2c7d60c3c43d25c7668f8.tar.bz2
gentoo-2-24ff1d049d8e2b04eeb2c7d60c3c43d25c7668f8.zip
Version bump.
(Portage version: 15155-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/bpython/ChangeLog8
-rw-r--r--dev-python/bpython/bpython-0.9.6.2.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/bpython/ChangeLog b/dev-python/bpython/ChangeLog
index 7c67f77d6e69..3531e7bfe1cf 100644
--- a/dev-python/bpython/ChangeLog
+++ b/dev-python/bpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/bpython
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bpython/ChangeLog,v 1.17 2009/12/31 06:49:38 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bpython/ChangeLog,v 1.18 2009/12/31 21:53:40 arfrever Exp $
+
+*bpython-0.9.6.2 (31 Dec 2009)
+
+ 31 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +bpython-0.9.6.2.ebuild:
+ Version bump.
*bpython-0.9.6.1 (31 Dec 2009)
diff --git a/dev-python/bpython/bpython-0.9.6.2.ebuild b/dev-python/bpython/bpython-0.9.6.2.ebuild
new file mode 100644
index 000000000000..1c43486833cf
--- /dev/null
+++ b/dev-python/bpython/bpython-0.9.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bpython/bpython-0.9.6.2.ebuild,v 1.1 2009/12/31 21:53:40 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_USE_WITH="ncurses"
+
+inherit distutils
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="http://www.bpython-interpreter.org/ https://bitbucket.org/bobf/bpython/ http://pypi.python.org/pypi/bpython"
+SRC_URI="http://www.bpython-interpreter.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+RDEPEND="dev-python/pygments
+ dev-python/setuptools
+ gtk? ( dev-python/pygobject dev-python/pygtk )"
+DEPEND="${RDEPEND}"
+
+DOCS="sample-config sample.theme light.theme"
+
+src_install() {
+ distutils_src_install
+
+ if use gtk; then
+ # pygobject and pygtk currently don't support Python 3.
+ rm -f "${D}"usr/bin/bpython-gtk-3.*
+ else
+ rm -f "${D}"usr/bin/bpython-gtk* "${D}"usr/lib*/python*/site-packages/bpython/gtk_.py
+ fi
+}